7

I created a clipping mask out of an image 3125x1042:

this: before-clipping

to this: enter image description here

Unfortunately, when I save the image as PNG and JPEG, It still retains the size of the original image. 3125x1042.

How do I get rid of the excess size to bring the image down to the exact size of the oval which is 151x150

  • 1
    Perhaps uncheck "Clip to Artboard" when saving? – Scott Aug 4 '14 at 22:19
  • thanks for the comment, but I don't see this option. – user26234 Aug 4 '14 at 22:46
  • Please provide more information then. "Clip to Artboard" is an option on the right side of the Save for Web window. – Scott Aug 4 '14 at 22:48
  • Oh, sorry. We got mistaken here. I'm talking about Export as opposed to Save for Web... – user26234 Aug 4 '14 at 23:31
6

If you want to save the file to jpg or png using the Export function with the dimensions of the artboard, you have to check 'Use Artboards', just above the export and cancel button in the export window.

When you select this option, you can also choose whether you want to export all artboards or just a selection.

Your chosen file name will be appended with the number of the artboard, or in case you gave the artboard a name it will add that to the filename.

1

You need to resize the artboard (using the art board tool SHIFT+O) to be the same size as the masked shape before you export it.

  • I did this. That's how I know it's 151x150. Anything I might be missing? – user26234 Aug 5 '14 at 13:28
0

Resizing the artboard to the exact size of the masked shape should have worked.

The only other thing I could think of is that just pressing SHIFT+O won't automatically resize the artboard for you - you need to manually bring in the corners so that you hit 151x150px before saving the file.

When you "File" -> "Save for Web" you can double check the size of the document to make sure you have the correct size you want.

0

I found the same problem. When saving to PNG the artboard size is not preserved.

The solution I found was not to Export but instead File -> Save for Web and there select restrict to Artboard size.

Cheers,

E

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy