I'm trying to import a .psd file into illustrator without showing the background. I have one layer in photoshop, showing only the transparent image. I've saved it as .psd, and .png files.

But whenever I open the .psd in Illustrator, it opens with a white background. Is there something I'm missing?

5 Answers 5

  1. Check and see that you are showing the transparency grid in Illustrator. View > Show Transparency Grid. Perhaps the transparency is there and you are not seeing because of Illustrator's default white "canvas".

  2. You may want to Place your .psd or .png file instead of opening it directly. This would especially be the case if you are using the image as part of a large composition.

  3. Ensure you are saving your .png file and including the transparency option. It's possible to have transparent regions within Photoshop, and lose them when exporting.


Try placing the psd file instead of drop and dragging it into illustrator. In Illustrator, go to file, place and locate the psd file to add it into illustrator.


It may help initially to select in Photoshop new page window for transparent background as opposed to the default white, so your initial file has transparency included.


Open the png file in Photoshop. Go image -> mode. Most likely "indexed color" will be checked. Change it to be RGB and save as png. Now the image should have a transparent background in Illustrator.

  • Can you add a screenshot? Does it work for every version of Photoshop/Illustrator?
    – Mensch
    Commented Nov 12, 2015 at 5:28

Make sure your image has a transparent background in Photoshop save the file. In Illustrator place the .psd file then go to Object and Image Trace choose Make and Expand, ungroup the image and remove the background.

Not the answer you're looking for? Browse other questions tagged or ask your own question.