5

How do I fix a font with a problematic kerning pair.

The problematic pair is capital T preceded by a space, when set in Helvetica Neue 55, and with kerning set to 'Metrics', using InDesign. The automatic kerning preceding the 'T' will change from (0) to (-125) resulting in the word space almost disappearing.

Typical scenario:

  1. I'm setting a document with some all-caps subheads in Helvetica.
  2. I decide subheads need to be a touch bolder, and change font from 45 to 55.
  3. Bammo. Now client thinks I don't know how to spell check.

The screenshot shows the difference between this font and the two weights either side (45 and 65), without any manual kerning.

Would you recommend I edit my Helvetica 55 and how would I go about that?

Or set optical as the default. Might this open a different can of worms?

And just say it's possible to fix the font itself, what then happens when I open old jobs with the amended font? Am I then looking for big spaces preceding 'T's ?

EDIT: I should add this is a Type 1 font.

enter image description here

  • Very interesting question. Not sure if this is design or tech support but hopefully someone can help you. I don't have a Helvetica license or I'd dig into it myself. – Ryan Sep 3 '14 at 12:58
  • are you sure this isn't maybe a setting/style in Indesign that's causing this? – DA01 Sep 3 '14 at 15:08
  • @DA01 Well that's a good question - so I just tested in Illustrator, and got the same problematic kerning. Also interesting: In addition to Optical and Metrics as options, Illustrator has Auto, and when set to Auto will behave like it's using Metrics, and display the problem. Metrics seems to be the Adobe default hence why I'm hesitant to change it. – MG_ Sep 3 '14 at 20:33
3

While I don't know what the guidelines and technologies are that would allow/enable modification of font software, I bet InDesign GREP styles would be a quick way to patch things up.

You can add a pattern of characters (in the example, .\sT) to the GREP Styles panel within a Paragraph Style dialog, and create a new Character Style to adjust kerning as necessary. I've included a screenshot that also colorizes the matched pairs, for clarity. The rule is added to a single paragraph style, but if you have a chain of inheritance all the way back to "Basic Paragraph," you could totally add it there.

The expression used to highlight the pattern is roughly: "Any character followed by a space, then a capital T."

InDesign GREP Styles

2

It sounds like you like the Optical setting, correct? Rather than globally changing your font file I would suggest creating a paragraph style in InDesign for your heavier subheads (if you haven't done so already) that uses Optical spacing and apply that style to the subheads in question. It won't change your default settings. It won't affect any other documents unless you import that paragraph style and apply it.

If you really want to go crazy, make two paragraph styles, call one "HeavySub_Optical" and the other "HeavySub_Metric" with the appropriate setting and then you can choose whichever one looks best for the text.

  • Thanks Kathryn, this is a good pragmatic answer. And while it serves the purpose of managing the problem, it won't save me if I forget. – MG_ Sep 14 '14 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.