2

I have been trying to convert an illustrator file to a 3D model for a few hours now, but I keep coming across the same errors.

I am using Maya, but I wouldn't mind using 3DS Max if it would fix my problem.

This is my path in Maya:

enter image description here

I have selected the main part of Australia and gone to Edit Curves -> Open/Close Curves to make sure all my curves are definitely closed. I then go to Surfaces -> Bevel Plus to turn it into a 3D object. Although, this is what happens:

enter image description here

Does anyone happen to know why it is not producing a perfect bevel of the path?

EDIT

Managed to extrude the path, although I am unable to close the faces now.

enter image description here

  • Oh, boy I have been in that situation. Try to reduce the complexity of the path. Try with different formats. In 3ds Max you can weld points based on proximity with the Weld modifier. Judging by the picture it looks that you tried to "mesh" the path and because the path has not normal information the bevel is not "beveling" properly. – Rosenthal Sep 9 '14 at 2:41
  • 1
    Try extruding instead of beveling. – Rosenthal Sep 9 '14 at 2:55
  • @Neo - Haha, tricky situation. All I tried to do was the steps I mentioned above, nothing else. The path is very complex, has 6967 points. How would I go about extruding? – Fizzix Sep 9 '14 at 3:23
  • what version of illustrator and 3ds max are you using? – Rosenthal Sep 9 '14 at 3:31
  • @Neo - Using Maya 2014 and Illustrator CC. I managed to extrude, although I can't seem to close the faces. Check out the edit to my question. – Fizzix Sep 9 '14 at 3:47
1

3DS Max Solution.

  • Convert your shape to outline in Illustrator, check before exporting it if the number of points is too high go to Pathfinder Options > Remove Redundant Points, then export the shape as your desired format.

  • Check if the scale of your scene is too small, 3DS Max does not work very well with minuscule objects, scale the scene up if you find it necessary.

  • Check if all the vertices are at the same level (the vertices must be contained in a 2 dimensional plane) , you can fix this by applying Make Planar to the shape.

  • Add a Weld modifier to the shape and make sure that all the vertices are connected.

  • Go into Utilities (the hammer icon on your command panel) and run 'shape check' on the spline, if no problem are detected proceed to the next step.

  • Add a STL Check Modifier, and check the shape for errors.

  • Extrude the shape with Cap Start and Cap End checked and with Mesh as Output.

Everything is lost:

  • In case you don't get the caps at ends try adding a Cap Holes Modifier, deselecting smooth new faces.

  • Try adding a Surface Modifier.

  • Check vertex by vertex that the shape is closed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.