3

When I update a shape in my Illustrator smart object, the object moves in my Photoshop document. This is very annoying; after every update I make in the design, I have to reposition the smart object again.

Is there a way to prevent the smart object layer from moving? Can I lock it? Or is there a way to setup the linked Illustrator file so that it won't move?

Thanks a bunch!

1

You might want to try and draw a large rectangle around your art in Illustrator, with no stroke and no fill. Do this before you place the Illustrator content as a Smart Object, and leave a considerable margin between your art and the inner border of the rectangle.

Photoshop will use the outer bounds of your Illustrator art to position the SO. In this case, that is your 'invisible' rectangle.

Downside of this method is that you'll have to know how big your artwork is going to be when you place it. It works well for small adjustments, though, especially if you draw the rectangle with a decent margin around your art.

To prevent accidents, it might be wise to lock the bounding rectangle in Illustrator.

  • I still wonder if there is a way without workaround, such a thing should be managable with settings i'd think. But for now I'm good to go. Thanks for your reply! – Daan Sep 11 '14 at 15:45
  • 1
    Any time. It would help the site if you'd choose an answer as the 'correct' one. Don't hesitate to wait with that for a couple days: maybe some other, better answers pop up. Once you hit 15 reputation, you can upvote any answer or question you consider useful. – Vincent Sep 11 '14 at 15:51
  • Sorry for the late reply, Yes i was waiting to see if maybe more ways/tips for solving this came in, but indeed i'll click the correct answer now, cheers! – Daan Sep 19 '14 at 16:02
0

Most likely you've changed the overall size of the art in the smart object. This includes objects in clipping paths, and transparent objects…

  • Indeed I changed the overal size. I think when using a psd smart object that should be a logic way of using it (changing the shape/size) and this should not influence the positioning. Or at least there should be a setting for it, so you can turn of this repostioning. But the workaround with a giant invisible rectangle described by Vincent works well. – Daan Sep 19 '14 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.