3

photoshop pixel art issue

I'm trying to set up Photoshop cc 2014 for pixel art graphics, but I have this weird issue where my pixels don't align to the grid. I can't work out if it's my pencil which is creating pixels too big, or the grid is somehow wrong. I've set the grid to 1:1 so I'm not sure how that could be any different.

Any ideas what I'm doing wrong?

I'm on a Mac if that makes any difference.

  • Whats the resolution of your file? – Rosenthal Sep 13 '14 at 16:16
  • 72 pixels/inch, standard photoshop setup. – Phil Sep 13 '14 at 16:37
  • @that's the problem – Rosenthal Sep 13 '14 at 16:39
  • 1
    How is that the problem? looking at this video youtube.com/watch?v=hFZBUWHVSrM he sets it up the same way. – Phil Sep 13 '14 at 16:40
  • Standard photoshop setup – Rosenthal Sep 13 '14 at 16:45
1

Because the resolution of your file is so big for pixel art Photoshop is showing you the other Grid (not the pixel grid), You have to disable the Grid:

View > Show > Make sure Grid is unchecked and Pixel Grid is Checked

enter image description here

Also: Reduce the resolution of your file to something like 24x24 and select a square brush.

  • Are you talking about the resolution or the pixel width/height? the res is 72 px/inch and the width/height is 100x100, what difference would making it 24x24 make? – Phil Sep 13 '14 at 16:46
  • Where is "Pixel Grid" ? I can't find that. – Phil Sep 13 '14 at 23:36
  • The resolution of your file is irrelevant as long as you are viewing it at actual size (or larger) – DA01 Oct 9 '14 at 2:36
1

If you want your "Gird" to match the "Pixel Grid" just set it up like this:

Gridline Every: 2 Pixels

Subdivisions: 2

  • It doesn't make any sense but it worked, thanks – Taly Emmanuela Jan 12 '16 at 11:59
1

You have to go to Edit → Preferences → Guides, Grids and Slices and then change gridline to 1 pixel (from the drop down menu) and subdivisions to 1. Then your grid will align with your pencil and canvas

  • Thanks for the contribution and welcome to GraphicDesign! Let us know if you have any questions – Zach Saucier Feb 24 '15 at 17:47
-1

This post is old but the solution is - switch everything to 2 - the pencil, as well as the grid divisions and subdivisions. Then switch back to 1 in everything. This happened in Photoshop CS5 for me in spite of everything being already set to one. So I switched everything to 2 then back to 1

  • Is that the same effect for the current CS? And what is the difference to the answer of Josh? – Mensch Oct 10 '15 at 1:25
-1

The correct answer is that you are zoomed out on the grid to far. Photoshop changes the grid size if the pixels are to small. Its not really a problem, just zoom in if you want to see the true grid size.

  • Wrong. That is the grid (which you can setup to whatever size you want) as stated in the accepted answer. – Luciano Apr 30 '18 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.