0

I have a long text with some hyperlinks in it. All hyperlinks except of one are automaticaly recognised and behave in PDF as hyperlink. One not. How to do it manually?

3
7

There are two things required for creating functional hyperlinks in a PDF from InDesign:

  1. Link defined in Hyperlinks panel
  2. PDF Export supporting hyperlinks.

If you've already created the definition in the Hyperlinks panel as @Scott recommended, then my bet is that you are using an PDF export that doesn't support interactivity, and those hyperlink settings are being ignored when generating the PDF.

I don't have version 5.5, so I can't verify exactly what your screens look like, but in CC, there are two ways to include interactive elements - it should be similar for you:

Option 1

Select Adobe PDF (Interactive) when choosing the filename:
Interactive PDF
Then set whatever options you like on the Export Settings dialogue.

Option 2

If you select Adobe PDF (Print), or if you only have one PDF export option when choosing the filename, then in the PDF options dialogue, be sure to make sure Hyperlinks is checked in the Interactive section.
Hyperlinks Checked in PDF Options

0

Select the text and add the hyperlink via the Hyperlinks Panel.

1
  • Already done, but nothing changes. In PDF, the text is still just a text. – Zbych Sep 14 '14 at 18:53
0

I just fixed this in my own document. I had the same problem, where all but one of my hyperlinks exported to PDF perfectly. I then realised that the link that I was pasting into the Hyperlinks panel didn't have 'http://' in front; I had pasted in a link that began as www. Once I added http:// to the beginning of the URL in the panel, it exported into the PDF perfectly. Hope that helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.