6

After creating a path with rounded corners in Illustrator, I added a dashed stroke and aligned it inside the path (but the problem is the same when aligning outside). Strangely I ended up with a lot of strange 'glitches' (?) along the path:

enter image description here

When aligned centered, the stroke looks neat and sharp:

enter image description here

I've tried changing stroke properties but nothing really helps. Has anyone ever experienced similar behaviour? How can I get those sharp strokes back?

To create this symmetrical shape I first created the left half, copied it, reflected the copy and united the both parts with Pathfinder.

Here's the actual document in case someone is interested: https://dl.dropboxusercontent.com/u/17682405/example.ai

  • Try change options to this (on the right side of the screenshot) - i.stack.imgur.com/XUSFy.png – Ilan Sep 23 '14 at 15:30
  • I've never seen or heard of such a thing. Is there a raster effect applied to the object? What's the Appearance Panel look like??? – Scott Sep 23 '14 at 16:01
  • Thanks Ilan, I tried the same thing but unfortunately that option is greyed out. – mat Sep 23 '14 at 20:08
  • Scott, I didn't raster anyhing. The Appearance Panel just mentions the "2pt Dashed Inside". Here's the actual document in case you're interested: dl.dropboxusercontent.com/u/17682405/example.ai – mat Sep 23 '14 at 20:10
  • Wow. I see it in your file here too.. no rhyme or reason for that. Looks to be some sort of drawing bug. Note it's happening on every curve of that path. I can't draw a path, apply the same stroke, and recreate the issue. I'm left to think that path is the problem itself. Was it imported from somewhere else? Other plug ins used? -- for example, if using VectorScribe, maybe it's a bug with that plug in. – Scott Sep 23 '14 at 20:21
7

Try these first:

  • Toggle the image preview between the CPU and GPU preview. This has been reported to possibly correct this issue (View > CPU/GPU Preview)

  • Ensure strokes are not set to align to the inside. Also reported to address the issue.


For this particular question......

I found the issue.....

Select the path and uncheck Align to Pixel Grid on the Transform Panel -- Solved.

Apparently it's some sort of drawing bug with Align to pixel grid.

It took me a bit to find this, but the misalignment across the collar started me thinking... why is that stroke not sitting on the path??? And that lead to the Align to Pixel Grid Setting.

In CC2017.. you need to check the little button all the way to the right of the Control Bar:

enter image description here

(Thanks to @cyptus for pointing that out)


If none of this helps . . .

You need to contact Adobe to address this technical issue. It may be a direct problem related to your specific system which can not be solved here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.