24

I try to draw a square or circle and it just doesn't work. I know it should have a fill and stroke, and even when I select colors, it's not showing. All I see is a square depicting the area where the shape has been placed, as if it was in a different layer or something.

How can I show the shapes again?

  • "as if it was in a different layer" = that's often the case. Is it on a hidden layer? – DA01 Nov 5 '14 at 2:42
  • I am also having this problem. Every opacity/transparency that I know of are all set to 1, but it makes no difference. Can't seem to find any other answer on the internet so hopefully someone can enlighten me. – user44186 May 22 '15 at 5:33
  • 1
    I have this problem with Inkscape on Mac. Stroke opacity is 0 by default. – kelin Feb 24 '17 at 11:13
35
  1. Make sure there is not simply another object in front of your shape. Raise to top to see if that's the case

    Inkscape raise to top

  2. Make sure it actually has a fill and/or stroke

    Inkscape Fill empty

  3. Make sure the opacity of fill and stroke is not 0

    Inkscape Fill and stroke opacity

  4. If the stroke/fill color is a gradient, make sure that it does not end outside of the shape

    Inkscape gradient ends outside the shape

  5. Make sure the layer is visible

    Inkscape Layer visibility

  6. Make sure the layer opacity is not 0

    Inkscape Layer opacity

  7. Set Display Mode to Normal

    Inkscape Display Mode

  8. Unset the Hide checkmark in object properties

    Inkscape Object Properties

  9. Release the mask to see if the object was masked with a disjunct shape

    Inkscape Release Mask

  10. Remove Opacity or Channel transparency or similar filters via the filter editor

    Inkscape opacity via filter

5

In inkscape i had the same problem. If i drew a circle or a square, only the stroke would show up. It used to work properly before then i dont know i must have accidentally changed the setting.Even if i selected colors for the fill it still wouldnt show up. My problem was only with the fill and in particular the "Flat Fill" option for fill. All the other options for Fill still worked fine.

To repair this issue for me now the following method works. Press Shift + Ctrl + P. Then maximise or expand the option. Under shapes. Choose Rectangle Then in the options on the right side change from "last used style" to "this tools own style". This seems to have fixed the problem for me. However i had to repeat the same thing for Ellipses if i want the circle to act normal again.

  • Thanks a lot. This answer saves a laser-cutting class. Many students are stuck in this problem. – Tim Wu Feb 6 '18 at 6:09
  • It only worked in the shape of the square, in the others it did not work. The problem was only solved when I deleted the preferences.xml file in the following path~/.config/inkscape – rafaelcb21 May 18 '18 at 12:36
3

If you don’t want to go through a ton of Inkscape settings that you might have accidentally set to some weird value, a shortcut would be to delete preferences.xml in Inkscape’s settings folder (which is located at ~/.config/inkscape for me). Obviously this way you will lose all other settings you may have made.

You can also override most, if not all, styles for an object by pasting the style of another object. So if you have visible objects and newly drawn objects are invisible, do the following:

  1. Select a visible object.
  2. Copy (Ctrl + C).
  3. Draw a new object.
  4. Paste Style (Ctrl + Shift + V).
2

When things aren't show up (like shapes) there are a few things that can be causing that apart from colors and stroke.

Go to Objects - >Fill & Stroke - > Fill tab and check to see if the fill is at 100%.

Also go to Layers and check if layer opacity is at 100%

1

I had a similiar problem. For me the answer was to in the fill section increase the opacity to 100% that seemed to give the box all its characteristics and not keep disappearing.

1

Click on view → display mode → outline.

  • This worked for me for viewing very thin lines (an acrylic laser etching service requires lines to be 0.01mm, which makes them not visible in). – thinkski Oct 16 at 19:39
0

I had this exact issue. First, I changed display to "outline" and saw that my shapes WERE there, just not showing. I selected one of the shapes, went to the "Fill and Stroke" menu -> "fill" tab (first one)-> click "undefined paint" (? icon). It resets the fill and stroke settings to default, making the shape visible again. I noticed two squares next to "fill" and "stroke". The first square by "fill" was transparent. The second square would match any color I clicked to fill the circle, but the circle stayed transparent. Just something to look for.

0

I had this exact problem in Inkscape 0.92 on Windows 10. Everything was invisible. I closed the program, restarted and all was fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.