3

I am using pattern in illustrator in separated layer of course and some text areas and line texts in another layer... when I save the file to a PDF format I got a very bad result as seen as the attached file is. it seems that every single object in the artwork takes a stroke. the area box takes a very tiny stroke as well as the line text and the patters in the background takes a little stroke too. the result is a whole mess. I figured out the problem is related to the pattern because when i remove it it solve the problem. so do you have any idea how to deal with that?

enter image description here

  • What PDF reader is in question? – joojaa Nov 12 '14 at 9:06
  • Adobe acrobat XI – hsawires Nov 12 '14 at 9:10
5

This is a result of the .pdf viewer you use, there is nothing wrong with your image. Each and every .pdf viewer is absolutely horrible at previewing .pdf files that aren't optimised for display on screen. Print-ready cPDFs are the worst offenders: areas with drop shadows (as Henrik notes) get an outline, and vectors that touch each other regularly get a 1-pixel gap. Amongst other problems.

These effects are almost always just the crappy preview quality—the same file will print flawlessly, and there's a good chance it will also render nicely when you open it in a raster program and convert it to pixels.

A good check is to zoom in on any white outlines you see: if they stay one pixel in width no matter the zoom factor, it's a viewer issue and you're good. If the gap does resize with the zoom factor, there's something wrong in your source file.

Never, ever trust any .pdf viewer when it comes to printable .pdfs. Therefore, it's also a good idea to keep printables away from your customer for review purposes. Those gaps will confuse them even more than they do you now.

  • thank you for your informative answer ... I just want your comment on this scrrenshot when I reopen the file in illustrator it seem like every object is slicing the background .. sure i don't trust any PDF viewer but also the result in not an editable PDF anymore, the reason why I go to PDF is to be editable. – hsawires Nov 12 '14 at 9:56
  • plz see my updated comment ... – hsawires Nov 12 '14 at 9:59
  • eh. .pdf is not a great choice for editable files in Illustrator, that's what .ai is for, or possibly .eps. You can always try and export to .jpg or .png to get a better preview. – Vincent Nov 12 '14 at 10:01
  • yes sure, but sometimes you may be forced to follow the printshop instructions! ... they need it as a PDF. – hsawires Nov 12 '14 at 10:04
  • 1
    then you's be best off working for yourself in an .ai file, and then export a .pdf copy, which you send to the print shop. The fact that the end product needs to be a .pdf doesn't mean you should work in one. That'd defeat the purpose of, for example, InDesign. – Vincent Nov 12 '14 at 10:13
2

My guess is that the PDF if doing something with the text when you have the drop shadow effect on the text. It will probably go away when if remove the drop shadow.

Will it give you any different results if you save your PDF as another PDF standard (there are some to chose from when you save your file from Illustrator)?

  • Thanks for the hint, I give it a try, actually i did export the file in TIF and it gives me a perfect result. the problem occurred only in any PDF profile using "convert text to outline" option in the advanced setting. – hsawires Nov 12 '14 at 9:25
  • It looks like the same outline is present on the image you also have a drop shadow on so it shouldn't have anything to do with outlining the text. – Henrik Ekblom Nov 12 '14 at 9:31
  • You are right, and this is what I get when I reopend the PDF in illustrator. see the result here it seems like the PDF is slicing every single object of my artwork over the pattern and extract it and re-render it as a separated object including the pattern. the problem with pattern too. – hsawires Nov 12 '14 at 9:38
  • Try to save the PDF and leave "Keep Illustrator Editing" and "Create Acrobat Layers" unchecked. – Henrik Ekblom Nov 12 '14 at 9:41
  • If that doesn't work, try to flatten your artwork before you save as PDF. You do that in the layers panel's menu, found in its top right corner. – Henrik Ekblom Nov 12 '14 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.