I am trying to fill a selected region using the bucket tool in Gimp. I want everything to have hard edges, no gradual shading unless I do it myself. However, when I fill the region I end up getting gradual shading on the periphery. Here is an example image: enter image description here

Is there any way to change this behaviour?


2 Answers 2


After a few minutes more of poking around in Gimp I finally noticed that the selection tool had an anti-aliasing option, that was turned on. If this is not selected you get hard edged fills.

  • 2
    Indeed. Selection softening/feathering is what is responsible for this effect. If you have a soft selection from another source, you can straighten it using the selections->threshold action.
    – jsbueno
    Commented Nov 25, 2014 at 18:27
  • @jsbueno Thanks for the hint! So if you do a "Path to selection" you cannot choose aliasing, but the "sharpen" tool does the job. Thanks! Commented Oct 26, 2015 at 23:59

In newer versions of Gimp, the checkbox Antialiasing is checked and disabled (at least for the rectangular selection tool). You can achieve an sharp selection without antialiasing by making your selection and using Select → Sharpen from the menu.

Update Only using Select > Border... on a rectangular selection creates a seemingly rectangular selection with anti-aliasing. A normal rectangular selection is not anti-aliased and thus sharp.

  • Welcome to Graphic Design SE. I can only see that antialiasing is locked to active for rectangle select, which is not surprising since there is no need for antialiasing for any rectangle aligning with the pixel grid. Still, sharpen may be an alternative to solving the asker’s problem.
    – Wrzlprmft
    Commented Jun 23, 2019 at 17:04
  • Thank you for the greeting and enhancing the style of my answer, truly appreciated. I'm not sure I'm understanding the term anti-aliasing correctly. My current understanding is, that anti-aliasing means adding shades of the color of the line around the actual line so it seems smoother.
    – DBX12
    Commented Jun 24, 2019 at 6:09
  • My current understanding is, that anti-aliasing means adding shades of the color of the line around the actual line so it seems smoother. – Yes, or in this case, modifying the intensity of the selection. Aliasing are artefacts caused by forcing a shape onto a pixel grid that cannot be perfectly represented on it. However, rectangles can be perfectly represented on a pixel grid and hence Gimp does not have to anti-alias when using a rectangle select. This is probably why you see it disabled. You should see it enabled for other kinds of selection (ellipse, free form, …).
    – Wrzlprmft
    Commented Jun 24, 2019 at 7:49
  • I was led astray by the Select > Border... feature which created an anti-aliased selection. The normal rectangular selection works fine without antialiasing. I updated my answer to include that.
    – DBX12
    Commented Jun 24, 2019 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.