1

For some reason, when two shapes (in my case, lines) in different orientations are combined into one layer, they alias different than expected.

To present what my issue is, here is how to replicate the strange behavior:

  • Start up Photoshop and create a basic blank document, I used 500x500.
  • Grab the line tool, create a new layer, and begin drawing a diagonal line. Hold shift to align it at 45deg.
  • Create another new layer, and draw a horizontal line. It should look like this:

the desired result

  • Now, select both layers, right click, and "Merge Shapes". To illustrate how it changes, I moved the diagonal line a bit – you can see how the vertical line (and the horizontal line) both have strange anti-aliasing now.

the undesirable result

If anyone has any idea how to prevent this, that would be awesome. I'm looking to export a single layer of merged shapes as a vector for use on my website, but this issue prevents me from doing that.

All help is appreciated. Thanks!

  • Hi Kieran, welcome to GDSE and thanks for your question. If you want to know more about the site, please see the help center or ping one of us in chat once your reputation is sufficient (20). Keep contributing and enjoy the site! – Vincent Nov 27 '14 at 18:38
  • just a hunch, but maybe it'll help if you turn on Align Edges before drawing the objects? – Vincent Nov 27 '14 at 18:40
  • @Vincent Thanks for the suggestion! I hadn't noticed that option before, and it was already turned on. Upon selecting the shapes and turning it off, it fixed my issue entirely. Thank you! I'll compose an answer that shows how to resolve the issue. – Kieran Utz Nov 28 '14 at 20:03
1

The issue seems to have been caused by an option in Photoshop, Align Edges. It was turned on, and because it was actively trying to "align edges", edges of shapes that were within the same layer were modified in an odd way as shown in the question.

It should be noted that shapes do not need to be redrawn to fix the issue!

  • Here, I have two line shapes on the same layer.

multi-shape layer with align edges

  • Select a vector selection tool of your choice, I used the Direct Selection Tool (A), and select the shapes that you want to fix, if applicable.

  • Find the Align Edges checkbox option in the tool-specific toolbar, located at the top of the Photoshop window by default.

    align edges checkbox option

  • Turn off the option. Shapes that are drawn on the same layer should not interfere with eachothers edges now, and if you had shapes selected, they will no longer exhibit the issues anymore.

enter image description here

Here is an official blog post from Adobe detailing the different options, categorized under Pixel Grid alignment: Align and Snap to Pixel Grid in Photoshop

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.