47

I'm having intermittent problems with GIMP, where the 'move layer' command suddenly stops working. The mouse pointer changes to the one below:

cursor

When I make an explicit selection, e.g. CTRL+A on a layer, then MOVE works again. But normally I can move whole layers without any selection (e.g. Select/None or CTRL+SHIFT+A). This stops working out of the blue and I have no idea why.

It behaves very much like when you press ALT in MOVE mode. Pressing ALT with a selection allows you to move the selection around, as opposed to move the layer. Pressing ALT without a selection gives the same cursor as above, which is perfectly normal. Somehow when my problem starts, it looks as if ALT-mode is stuck and I can't get out.

Note I am a rather seasoned GIMP user and I use keyboard commands a lot, perhaps I switch too fast between commands, but I haven't been able to consistently reproduce it yet. Happens once every few hours or so. Only solution I found so far is to quit GIMP and restart. Other functions continue to work, I can still save etc (luckily).

I'm using GIMP 2.8.2 on Windows.

Thanks for any pointers.

  • I ran into this because I used <kbd>Alt</kbd>+<kbd>Tab</kbd> to switch between two GIMP windows. – Kenny Evitt Feb 7 '16 at 16:37
69

Looks like your move tool is in 'Move selection' mode. Check the Move setting in the tool options (this image is from the docs and shows Move layer mode):

GIMP Move tool options

The Alt key toggles to the 'Move selection' mode (Ctrl does the same for 'Move path'), and is supposed to switch back to 'Move layer' once you let go of the key. If you manage to steal the input focus from the canvas while in this mode, then the tool may remain in 'Move selection' mode.

See the following bug report for an example: https://bugzilla.gnome.org/show_bug.cgi?id=732160

So to answer the question and solve the problem, you should set this back to 'Move layer'.

However, for me in GIMP 2.8.14 the cursor stays like this only until I actually try to use the tool again; it switches back to 'Move layer' mode automatically then.

  • 6
    OMG, thank you for this! It was driving me crazy! – SsjCosty May 4 '16 at 10:52
  • 1
    I know you're not supposed to just say thanks but you're a lifesaver! – dldnh Nov 3 '16 at 0:48
  • I was flipping tables. – Seth Oct 2 '18 at 0:33
  • Gimp is just so awful when its comes to UI – Jamie Hutber Jul 14 at 23:19
  • @JamieHutber we're always open to suggestions, but please make them read like you have invested more than five minutes of your time into them :) – Michael Schumacher Jul 15 at 13:37
4

Not exactly an answer but related. To view Toolbox Options on mac, which can be a bit tricky to find, is one of the 'tab' next to layers and can be activated from Windows > toolbox Options - brushes

enter image description here

  • FYI, on Windows at least, you can also double click on a tool (e.g. the move tool) to activate/open the Tool Options for that tool. – geert3 May 20 '17 at 11:19
  • If you have the panel open, you can find it in selection menu. – arenaq Feb 6 at 14:25
1

I ran into this problem where I couldn't move the layer. I tried setting tool options appropriately and even resetting the tool options. It turned out I had a layer mask on all my my layers so when I selected a layer it was selecting the mask instead of the image. I could see the boundary moving, but the image was stationary.

Selecting the image after selecting the layer solved this issue for me.

0

Ran into a similar problem (for text boxes) where the Move tool would not change focus (ie: dotted outline changes to the text box I click on. Turns out I had the Layers windows in 'Paths' mode. When I switched back to Layers, the problem was 'fixed'.

  • Uh? What to you mean by Layers windows in 'Paths' mode? – xenoid Dec 8 '17 at 22:15

protected by Mᴏɴᴋᴇʏ Jan 8 '18 at 18:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.