4

I'm editing a template with a baseline grid. I added an icon with Font Awesome and can't align it vertically with my text because it snaps to the baseline.

How can I tell InDesign not to align this particular element to the baseline grid? Turning off Snap to Document Grid and Snap to Guides didn't work.

InDesign snap to baseline grid

4

For inline elements you can merely highlight the icon with the Text tool and adjust the baseline to reposition the element.

Dingbat....

enter image description here

Inline vector....

enter image description here

  • Some of the other answers here are totally confusing for someone landing on this question. The 'Align to baseline grid' / 'Do not...' buttons will affect the entire paragraph not just the selected icon. I suggest we clean up these answers. Your answer actually describes the proper way to do this. – Lucian May 16 '17 at 19:16
  • This is just another method @Lucian A method I prefer, not necessarily the "correct" method. The other answers are not necessarily "wrong" either. They just have a different workflow. Deleting answers or "cleaning them up" would be inappropriate. One of the other answer may be exactly what helps some other reader. – Scott May 16 '17 at 19:26
  • Fine with me, you should probably know better :) – Lucian May 16 '17 at 19:28
  • @Lucian this exactly happened to me. I was looking for how to stop an entire paragraph from snapping to the baseline grid. Another answer helped me accomplish this. – Daan Mar 15 '18 at 13:16
2

I figured out a solution.

I can move the text if I convert it to outline.

  1. Select text
  2. Type menu > Create Outlines or hit Shift+Cmd+O

Is there a better way of doing it?

1

You should be able to add/modify a paragraph style to achieve this. Check for:

Do Not Align To Baseline Grid

or set

Align to Grid : "None"

Not sure how exactly this is named in all versions.

1

A workaround for this (obviously not the proper proceedure) is:

  • Select the element
  • Cmd+B for Text Frame options
  • Tab+B for Baseline options
  • Check "Custom Baseline Grid" and enter an increment of 1pt instead of spacing default 12pt. This will allow the text box to 'float' nicely without snapping to the Baseline grid.
1

Navigate to Window > Type & Tables > Paragraph.

Windows: CTRL + ALT + T

Mac: CMD + ALT + T

In the right bottom corner there are 2 icons:

  • Do not align to baseline grid
  • Align to baseline grid

InDesign CC align to baseline grid

0

When you say align vertically, I assume vertically center?

If you don't want to outline the text, I'd try the following:

  1. Select both the text and icon
  2. Cmd+B, change vertical alignment to center
  3. Try aligning again using the Align palette.
  • Just tried this and it didn't work. I guess a baseline grid enforces all text to stick to the baselines. – Nelu Dec 18 '14 at 16:18
0

Another thought, if you're working from someone else's file.

My text was jumping around very wildly like there was a text wrap or baseline grid issue, but they had set up a paragraph style which was causing the issue.

When I highlighted my text block and clicked on "Basic Paragraph" style, I was able to then choose a font style which didn't jump around.

I'd never had that issue before!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.