I have two shapes (left) and I have added rounded corners to the rectangle on the top one using the "Rounded Corners" menu item.

When I select the two shapes and choose "create mask" I want Illustrator to make a mask of the actual shape with the rounded corners and not of the rectangle that existed before I added the rounded corner effect.

However Illustrator gives me the actual result (middle). I want the desired result (right).

How can I do this?

example of desired and actual result

This is what my layers palette looks like:

layers palette screenshot

4 Answers 4


I am not certain why Illustrator does this, but there is no question that it does. Here are two workarounds that you can use:

  1. Change the Order of Operations - First create a regular, unrounded rectangle and apply it as a clipping mask onto the other shape. Only then apply the Rounded Corners effect to the mask. This works for me in CS4.

  2. Create an Opacity Mask Instead - Create your rounded rectangle as before, but color it white with no stroke. Then select the shape to be masked, go to the Transparency panel, and use the little menu icon at the top-right to select ‘Make Opacity Mask’. This will create an opacity mask, which you will see as a black square in the Transparency panel. Cut your rounded rectangle, then select the opacity mask (black square) and paste the rounded rectangle inside. You have to select the opacity mask to work inside it, and then select the square to the left of it in order to resume working on your illustration. It’s a mutually exclusive drawing context, kind of like in Photoshop. Always switch back from the opacity mask, otherwise you will get confused as to why your mouse clicks aren’t doing anything.


Expand your shape before using it as a mask and it should work correctly.

To expand your shape, select it and then go to the 'Object' menu and click on 'Expand'.

Expanding will permanently modify the shape to have rounded corners whereas just adding the rounded corners as an effect will only temporarily modify the shape to have rounded corners.

  • how can i do that?
    – cwd
    Nov 15, 2011 at 12:09
  • I edited my answer to include how to expand your shape
    – zachzurn
    Nov 16, 2011 at 8:26

"Rounded Corner" is an effect applied to the regular rectangle path you created. For display, Illustrator will show the rounded version, but for other purposes it interprets the shape as the original path.

Have you tried using the Rounded Rectangle tool from the Tools palette instead?

This doesn't have the advantage of being non-destructive (i.e. the corner radius is set at the time of creation), but it will do what you need.

  • I thought I tried that without luck, but I can try again. Is there a way to adjust the radius on the rounded rectangle after it is created?
    – cwd
    Nov 10, 2011 at 19:06
  • The rounded rectangle tool may be hidden in the latest versions of AI and not present on your basic toolbar. To add it select the three horizontal dots at the bottom of the toolbar "..." scroll down to the rounded rectangle, then drag the small rounded rectangle icon on top of your other shaped on you toolbar (ellipse tool, rectangle tool etc). This will then add the rounded rectangle tool option to the shapes.
    – MikeyBunny
    Jun 18, 2019 at 15:31
  • To adjust the radius of the rounded rectangle corners, first draw the rectangle using the rounded rectangle tool, then select Properties and look under transform. Here you should find 4 rounded corner options (you may have to select the "..." more options at the bottom right of this area to see these).
    – MikeyBunny
    Jun 18, 2019 at 15:36

Shape Builder Tool (Shift + M)

Play around with that before trying to make a Clipping Mask. I spent more time than I'd liked trying to make the same type of thing work.

  • Its not the same thing. There are things that a clip can do that would be impossible with other methods. Also its not really topical anymore as illustrator has changed in 12 years
    – joojaa
    Mar 16, 2023 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.