-1

I'm having problems as Indesign acts kinda stubborn. It keeps giving me an odd space between a word. I've tried to readjust the spacing using paragraph styles, font size, changing the font, spacing, leading as well as tried to re-adjust the width of the container. Unfortunately none of these attempts have resulted in any success. Can you please give a hint ? I have a very important project that I want to finish as soon as possible.

indesign spacing gap

  • I am having the same issue. However, left align or justification doesn't make a difference for me, InDesign still gives me odd gaps> This is driving me nuts. Any idea of what is going on? Thanks! – Jose Javier May 21 at 20:06
6

When you justify text rather than leaving it left-aligned, InDesign has only so many ways to adjust things so that the right margin lines up. By default, it does this by adjusting the spaces between words. In this case, you are using a very large point size in relation to the width of the line, which forces InDesign to make a wide space between the only two words that will fit on that second line of text.

When you have a very narrow column in relation to the point size of your text, never use full justification. Left-aligned text will avoid those ugly gaps.

| improve this answer | |
  • 2
    The other alternative is to have fixed width word spacing and to have uneven letter spacing. (Just typing that makes my skin crawl.) – usr2564301 Jan 3 '15 at 9:00
  • Hi, thanks for the answer but what if I wish to create a square'ish block of text with a bold font (that from far looks literally like a square) ? – Danny_Student Jan 4 '15 at 1:13
  • 2
    Set different lines in different point sizes (big, exaggerated differences) to achieve that. Big, blocky sans typefaces work best for this. – Alan Gilbertson Jan 6 '15 at 19:07
  • You have extra possibilities by editing the Paragraph Style and selecting Justification in the left menu. There you can adjust word spacing, letter spacing and glyph scaling. There is also an option to how it should behave if a single word is on a line. (Though it is possible doesn't mean that it is smart to use it ...) – 2rB May 22 at 9:50
1

I figured out my issue. There was a white box in the template, which covered that area of the text. The text was simply being pushed around by the box's wrapping setting.

I hope this info can help someone. Some times we leave elements floating aeound, be it in the template or in in the text box area itself that can trigger unwanted behavior.

I found the issue while doing a CTRL+All while taking a look at the template being used for that particular page. I noticed the "invisible" elements and wallah!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.