2

I'm not a professional user of anything Adobe makes, but I am a programer and I do understand math, which is probably why this hurts my brain. I open a new empty Adobe Illustrator CC document, set the dimensions to 250px x 250px, set the Artboard center markings on, place my cursor and create a circle 25px across, I carefully use the transform tool to move it -12.5px x and y, and then make my next circle, this time 30px across, and transform it -15px x and y, and I notice it looks wrong. I loose 15 minutes mucking around with the idea perhaps I turned something stupid on with perspective then give up and try to reproduce the 'bug'. I make 2 new circles, each time doing a right click, and transform manually so that they are centered, then move it to the back of the layer stack so the circles in front are visible.

I get a weird "saggy bulls-eye" effect like each circle has warped either high or low and I have no idea why. Explanations?

Circle 1

  • 1
    They're probably thrown off by the pixel grid alignment, which is only noticable when you're using an artboard with a small pixel width and height and looking at it at a high zoom factor (yours is at 1200% !). Try turning the pixel grid alignment off (CTRL + A -> Uncheck the last checkbox in the transform panel) and then realign them centered to the artboard. Or just zoom out to 100 % zoom factor, you probably won't notice any distortion at all ... Note that by turning off pixel grid alignment, your objects might be interpolated during export to an image file. – MoritzLost Jan 5 '15 at 13:41
  • 1
    Also, in the "New Document" panel, there is an option to have new objects automatically aligned to the pixel grid. If you're having trouble with it, you can turn it off later on in the flyout menu of the transform panel. – MoritzLost Jan 5 '15 at 13:45
  • 1
    @Gin-San You should probably post both these comments as an answer so they are more visible, I may have answered my own question, but you at least deserve an up vote for the additional information about the default mode for new objects. – Techdragon Jan 7 '15 at 5:37
  • This doesn't explain what's happening, but a super-easy fix is to use the alignment tools to center the circles on each other both vertically and horizontally. – DA01 Jan 7 '15 at 16:02
1

For anyone that has something like this happen to them. It turns out at this small scale the pixel grid was throwing my shapes off in a nice even pattern. Manually realigning the centers fixed it.

1

They're probably thrown off by the pixel grid alignment, which is only noticable when you're using an artboard with a small pixel width and height and looking at it at a high zoom factor (yours is at 1200% !). Try turning the pixel grid alignment off (CTRL + A -> Uncheck the last checkbox in the transform panel) and then realign them centered to the artboard. Or just zoom out to 100 % zoom factor, you probably won't notice any distortion at all ... Note that by turning off the pixel grid alignment, your objects might be interpolated during export to an image file.
Also, in the "New Document" panel, there is an option to have new objects automatically aligned to the pixel grid. If you're having trouble with it, you can turn it off later on in the flyout menu of the transform panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.