6

I have a frustrating problem with Chinese text in Illustrator. I am updating some graphics by changing English text to Chinese. I have been provided with Chinese translations in a Word document which are all entirely legible (if you read Chinese, of course). I have approached this in 3 ways and all 3 have thrown up problems:

  1. Select and copy text in Word. Double click text in Illustrator so position is preserved, paste text. This sometimes works, but often several characters will be replaced with a crossed box (ie 'no character'). The font is set to SimSun in Word, but for some reason transfers to Kozuka Gothic when pasted. So I try and set the font back to SimSun, but it refuses to change.

  2. Select and copy text in Word. Delete English textbox completely. Paste Chinese text directly into Illustrator. SimSun font is preserved and all characters show... but the text has a huge bounding box extending way out to the right, filled with empty characters. This means I either have to edit each text box and delete those characters, or deal with lots of overlapping bounding boxes.

  3. Select and copy text in Word. Paste it into Notepad to remove extraneous formatting. Paste into Illustrator. Bounding box is properly sized, but font changes to Kozuka Gothic as per 1.

Does anyone have any idea how to overcome this?

3

Most problems with Chinese type resolve by changing the language (that little dropdown at the very bottom of the Character panel) to Chinese. If you change the language of the text frame to Chinese before you paste in the text, you should be okay.

This also holds true for individual CKJ characters in otherwise English text, in both Illustrator and InDesign (and probably Photoshop, although I've not had occasion to find out). You'll see errors unless you change the language of that character (or character style) to the correct one for that character.

  • Chinese doesn't appear on my list of languages in Illustrator... – user36735 Jan 9 '15 at 10:38
  • 1
    Sounds like it's time to delete preferences or uninstall and reinstall, in that case. – Alan Gilbertson Jan 9 '15 at 19:18
  • @user36735 I agree with AlanGilbertson TTF fonts should be appearing in Illustrator. – Troy Woo Jan 22 '15 at 17:57
1

I had a similar experience as Kim. His solution worked for me, but I could edit the Chinese character text afterwards as well. What I did:

  • Paste the Chinese characters inside Notepad
  • Print notepad file using Adobe PDF and save on the desktop.
  • Open the PDF in Illustrator as a new document
  • select the bounding box with text and
  • copy paste inside your illustrator document

So I guess that using adobe pdf as printer opens more features.
Note: I have a license for adobe acrobat DC.

0

try this:

  • in Illustrator with nothing selected select SimSun as the font. This will update the default font to SimSun.

  • copy the text out of Word and paste it into Illustrator.

PS this also works for fill/stroke settings - the "default" is updated if you change the settings in the toolbar with nothing selected.

0

According to https://helpx.adobe.com/illustrator/using/formatting-asian-characters.html

Display Asian type options

By default, Illustrator hides Asian type options in the Character panel, Paragraph panel, OpenType panel, and Type menu.

  1. Choose Edit > Preferences > Type (Windows) or Illustrator > Preferences > Type (Mac OS).
  2. Select Show Asian Options, and click OK.

You can also control how font names are displayed (in English or in the native language) by selecting or deselecting Show Font Names in English.

0

enter image description here Outlook for illutrator: copy the text and paste into illustrator without open text box. select this text box and copy again. open text box and make paste. Chinese characters will appear

0

I know this post is 2 years old now, but I was having trouble and came across a way around the problem that worked for me. I tried the other suggestions above and nothing worked. What did work was this:

  • Copy text from Word doc and paste into TextEdit... export TextEdit file as PDF.
  • Open TextEdit PDF in Illustrator as a new document.
  • There will be a long bounding box but you can just double click it and delete.
  • From there you won't have actual text but you at least have outlines to work with.

It's kind of an obnoxious way to go about it but at least it's something!

0

Using a font with a wider range of Chinese characters solved the missing characters issue (crossed boxes) in Illustrator when copying and pasting Chinese for us.

For example, Search for 'Traditional Chinese' at Google Noto Fonts.

When text is rendered by a computer, sometimes characters are displayed as “tofu”. They are little boxes to indicate your device doesn’t have a font to display the text.

Google has been developing a font family called Noto, which aims to support all languages with a harmonious look and feel. Noto is Google’s answer to tofu. The name noto is to convey the idea that Google’s goal is to see “no more tofu”. Noto has multiple styles and weights, and is freely available to all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.