I am working with this "complicated" ilustrated cat character in Illustrator. The problem is that I worked and modified what I needed to modify and now I have to resize this cat and I stumbled into a weird issue. Its all vectors, no raster effects. No strokes on it, only Filled Shapes. When I resize it some paths seem to move a little, like for example the glasses on its eyes are not in the exact same position when I make it smaller... I tried diffrent ways, if I resize from a corner and hold Shift + Alt it doesn't work, if I resize from a corner hold Shift without Alt its a little better but still... stuff moves around, only a little, but... it moves... If I group certain elements I get better results when I resize, but still...STUFF MOVES AROUND... WHY ?!

has anybody else encountered this issue before ?

I think it has something to do with compound paths...i have a feeling, cause I get this error only on strokes that I expanded(using Object > Expand) and on paths that I modified using Offset path...

Have a look at the image to see what I mean, look how the glasses changed and the frame is diffrent :

enter image description here

enter image description here

This happens when I double click the glasses(I go inside a group that has inside it a Compound Path... ) enter image description here

Note: the glasses look ok when I simply double click them and enter the group>compund path, i just moved things a little in the screen shot to illustrate that this is what happens when I resize them... HELP :)

  • Hey. Could you please post the exact steps you took to create those glasses? Or better yet, create the glasses again, record the steps, and post them here if the problem persists. Thx :)
    – Alexei
    Nov 16, 2011 at 0:31
  • I did them with a Rounded Rectangle, a 3 px stroke with no fill, then I Expanded the stroke... so now its a Compund Path... it there an alternative ... so its not a compund path? it seems this only happens with the compund paths... whatever that means :P (its like a path inside a path or something like that, like a mask thats not a mask cause it jut not.. i dono, i kinda understand it but not completly..) Nov 16, 2011 at 0:42
  • I thought that the "up side" when working with vectors, you can RESIZE everything to whatever size you want and NOTHING happens... but.. sometimes it does, especially when you have to get things done by tomorrow... everything goes bad where it has never gone before... just to make things a little more "fun" Nov 16, 2011 at 0:48
  • Ok.... I tried releasing the Compound Path... then remaking the glases using two rounded rectangles and the Pathfinder tool(Minus Front), that also results in a COMPOUND PATH... and when I resize... stuff looks like in the last screenshot... im lost... Nov 16, 2011 at 1:05
  • Uhum... i tested things a little more, thats definetly only happens with grouped stuff... and for sure with Compound Path objects, just try this: make a big rectangle, then a smaller one inside of it, then cut the smaller one into the big one using the Pathfinder Panel(i said tool before.. its panel.. or who realy cares, if you know illustrator you know what I mean) After you have the rectangle "donut" kind of object try resizing and see what happens with the smaller rectangle(the one thats not actually there, the hole in the rectangle donut) IT MOVES! Nov 16, 2011 at 1:16

9 Answers 9


If you are using cs5 and have align to pixel grid checked in the transform pallet. Then possibly that is causing the problem. I have had many issues with the align to pixel grid box checked. Outlined text especially gets messed up.

  • yup, i had issues with this also, you might be right, I'll check and get back to you :) Mar 13, 2012 at 12:11
  • Many thanks, your guidance has just really helped me out. I was moving a web design into a print context and having expanded all paths I was still getting issues with some paths distorting. Certain objects in the design had align to pixel grid on. Unchecking this removed the issue.
    – user570
    Apr 13, 2012 at 12:59

When you double-click you are entering Isolation Mode. In Isolation Mode many objects may act as independent objects rather than groups or compound paths.

From the appearance of your "after scale" image it would seem you only grabbed one part (the outside) of the compound shape and scaled it. You simply need to be certain to select both the inner and outer paths before manually scaling. That's all.

To exit isolation Mode, just tap the ESC key.


The issue could be that the shape of the glasses may not be expanded properly (it got bugged somehow). You can try to "re-expand" it buy creating another shape inside of the glasses shape (just a little square inside the boundaries of the glasses shape and via pathfinder Add it).

This can re-expand the shape, basically reset it and hopefully get rid of the bug. I haven't encountered this bug, but I have been using this method to deal with other issues, and it has worked thus far.


to scale accurately:

Make sure all you want to scale is grouped or selected.

Expand them.

Make sure preference "Scale strokes and effects" is checked.

Drag scale: hold down shift.

Transform scale: enter percentage.


Yes Chet Tailor is right use Object>Path>Outline Stroke. Not Object>Expand Because i used Object>Expand so at that time i'm also facing the error like cat's glasses.

  • Sorry Guys that error is still occur. I tried one more time.
    – Sachin
    Feb 25, 2019 at 13:29

Ai has display and offset problems since it exists. This mostly happened (with older versions) when you zoomed in/out. I guess Ai simply doesn't work too good together with some (lots) of graphic cards. To prove yourself that you're not doing it wrong: Simply print it from your current state of zoom and you'll that everything's alright. You just have to get used to it and ... well, ignore it.

  • might be... I'll try... but if its like this it should work when I export it as JPEG/PNG/PDF etc... so lets see! Nov 29, 2011 at 9:43
  • I guess you got me wrong: There's nothing that can fix that (aside from maybe some patch for Ai). Sorry, it's just display: don't worry, just print, see & relax :)
    – kaiser
    Nov 29, 2011 at 14:26
  • I got you, what I meant is that if its just diplay then if I save as PDF and print it should be alright... or any other format... if its just display Nov 29, 2011 at 20:28
  • @FlaviusFrantz Sry. I don't understand what you write. Could you try again?
    – kaiser
    Nov 30, 2011 at 1:30

create de objet or group of objets and before rezise convert into Symbol with F8 key, and then you can make anithig with that , and dont make crazy things.



I didn't want to leave this question like this... the answer is not the best solution in all situations, but

this is what I did to get rid of my problem :

I re-installed Illustrator... Problem status : Not Solved.

I re-installed the OS and then Illustrator... Problem Solved

So i guess it was a bug, an error in matrix somewhere, I want to remind you that I tried deleting the Preferences for Illustrator before all this, so the software should have been back to its default settings/preferences, that did not work, its either that Illustrator saves some more stuff elsewhere or something just went wrong on my machine...

If this ever happens to you... this is the best and "short" sollution

  • I wouldn't consider reinstalling my OS the best and shortest solution, but I'm glad it worked for you :p
    – Hanna
    Nov 29, 2011 at 7:54
  • @Johannes Yeah... you're right.. in the end its back to where I started, Illustrator is doing it again... only on compound paths... deja vu cat i'm designing is the cause of the problem... im sure... the agents have changed something in the matrix again... Nov 29, 2011 at 9:39

From the steps described you may have done it a different way that gives you a slightly different result.

To turn a stroke into a fill you would use the following steps.

Select the stroke with the selection tool (the black arrow).

Then from the menu: Object>Path>Outline Stroke.

Not Object>expand

Hope that helps.

  • -1 : object > expand has the option to expand both the stroke and the fill, why don't you recommend using it? have you noticed bugs or anything ? Mar 13, 2012 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.