9

I am using Illustrator 17.1.0 to prepare some scientific figures. I have two layers: the bottom one has some placed PDF figures and the top one has annotations.

When saving this as a PDF, the placed figures simply don't show, regardless of the PDF viewer being used (Acrobat, Mac Preview).

Why does this happen? Is this a common/known problem? Is there a solution other than embedding the placed figures?

The reason why I use placed figures is that they're generated by a plotting software and I wanted to make it easy to update them when necessary.


Here's a link to an example showing the problem. plot.pdf is placed and annotated_plot.pdf is saved from Illustrator with "Preserve editing capabilities". When opened with illustrator it shows everything correctly, but when opened with any PDF viewer, it doesn't show the placed file.


This appears to be a bug in Illustrator and happens when placing any PDF exported by Mathematica version 10. It does preserve the placed PDF file, but it sets the bounding box to be of zero width.

Possible workarounds (other than embedding), only for the case when the placed PDF uses no transparency:

  • Re-save the file using Mac Preview before placing it.
  • Re-process the file using GhostScript before placing it. gs -q -sDEVICE=pdfwrite -sOutputFile=output.pdf -dBATCH -dNOPAUSE -c save pop -f input.pdf Using the command-line is advantageous for batch-processing or automation.
  • Thats weird never noticed this i have to look into this. – joojaa Jan 26 '15 at 18:17
  • Ok ive located the error. The file is actually embedded its just obscured by a broken clipping path definition. Might actually be a bug in BOTH mathematica AND illustrator. – joojaa Jan 26 '15 at 18:51
  • @joojaa Thanks! I talked to a GhostScript developer on IRC and he found the same. This only happens when transparency is used in the file and for some reason Mathematica uses a transparency definition even if all objects are opaque. What GhostScript does when it processes the PDF is just remove this unnecessary transparency. Well, this is what I was told and it's based on this feedback that I assumed this to be an Illustrator bug (originally I assumed it was Mathematica's fault). Here's a much simpler PDF exhibiting the problem. – Szabolcs Jan 26 '15 at 19:18
  • Yes, im looking if inDesign does this same thing. Mathematica i can reproduce this with a simple graphics arrow primitive. – joojaa Jan 26 '15 at 19:23
  • Yes its a bug in illustrator. Time to file a bug report. – joojaa Jan 26 '15 at 19:26
6

(Reposting my answer from this thread.)

Setting Compatibility: Acrobat 4 (PDF 1.3) in the Save Adobe PDF dialog in Illustrator solves the issue (checked with Illustrator 17):

screenshot

In the resulting PDF file the transparency will be flattened without rasterization.

  • 1
    I had this problem on OSX Yosemite when the embedded file was a PDF exported by Mathematica. This answer solved my problem, thank you. – wil3 Jan 28 '16 at 3:36
  • Same fixed it for me too, OSX El Cap – Esteban Mar 24 '16 at 23:02
2

Embed the plot rather than linking to it.

Unlock the layer with the plot on it and then highlight the image in the Links Panel and from that panel's menu choose Embed Image.

Then save the PDF.

PDFs do not link to external files. So, the linked image in your AI file is not being included in the resulting PDF. To be perfectly honest, I'm not sure why this is happening. It almost appears to be a bug of some sort. When saving as a PDF, the save engine should be smart enough to know that images are wanted and it should embed them automatically.

  • Thanks for the response, but embedding is very inconvenient for me (as I mentioned in the question) so it's not a solution. If I had to resort to embedding and all the additional trouble it brings then I'd rather not use Illustrator at all. – Szabolcs Jan 25 '15 at 16:32
  • Hm, it seems that the problem is related to the PDF files I'm trying to place. It only happens with PDFs exported from Mathematica 10.0.2, but not most other ones. These PDFs must be broken in some subtle way that is not reported by Acrobat. – Szabolcs Jan 25 '15 at 16:35
  • Scott, do you have Illustrator CC 2014? If yes, could you please try "placing" the PDF I linked ("plot.pdf") onto and empty artboard (without embedding) and saving it as PDF again, to see if CC 2014 also has this problem? I don't want to go to all the trouble to ask our IT dept for CC 2014 and resintall everything unless I know it will help. The problem only appears with certain PDF files (like the one I linked) but I have reason to believe that this is a bug in Illustrator and not a problem with the PDF itself. – Szabolcs Jan 26 '15 at 17:53
  • As posted in my answer.. it appears to be a bug of some sort. – Scott Jan 26 '15 at 17:55
  • You mean you already tried it with CC 2014? I only have the original CC (Illustrator 17) and CS6 available at the moment, both show the problem. – Szabolcs Jan 26 '15 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.