2

I am having a very hard time trying to align my text (among other elements) to my grid.

I want the text area to line up flush to my grid lines.

enter image description here

  • What exactly do you want? If you enabled align to grid (⇧ + ⌥ + <) the texts baseline should align to the grid. To Align the first character, to the grid, you need to create outlines of the text (⌘ + ⇧ + O), but it looks like you did that for “Keith”. The other characters do not get aligned to the grid because it would result in awkward kerning. – Afterlame Feb 5 '15 at 12:53
  • Hi. I want the "Front End..." text to line up flush to the left line. Like Keith does. Both are editable and not outlines. – Keith Donegan Feb 5 '15 at 13:36
  • It seems, indeed, that there's a distance between the left edge of the text object and the left edge of the first character. I usually go by eye for this, but if there's a better way, I'm curious, too! – Vincent Feb 5 '15 at 14:18
5

The type designer defines where the letters begins in the text box. If you want to make sure the path lies flush to your grid line, you have to work around this. The easiest way is to make use of the convert to outline function. However, if you want to keep the text editable, you can use this workaround:

A step-by-step breakdown:

  1. Set the x-value of your text to the value you want your text to stand in the end
  2. Duplicate the text at the same position (Cmd + F)
  3. Convert the text to outlines (Cmd + Shift + O)
  4. Copy the x value of the outlined text
  5. Delete the outlined text
  6. Subtract the copied x value from the x-value of your original text.
  7. Enjoy your perfectly aligned text
  • Thank you. This solves the issue. Just very strange the way illustrator doesn't have an easier way to accomplish this task. – Keith Donegan Feb 5 '15 at 14:46
  • Yeah, this bugs me every time I set one-liners. For text blocks this behavior is the way to go, but one liners (especially titles) always look off and have to be adjusted manually. If you change the text later on, you have to re-do everything. This is also the case in inDesign, where this becomes a bigger problem … – Afterlame Feb 5 '15 at 15:02
1
  • draw a vertical line right on the grid
  • remove stroke (and fill if necessary)
  • select you text item
  • go to Effect->Path->Outline Stroke
  • select both, the text and the line
  • hit Ctrl+K to bring up preferences and check "Use Preview Bounds"
  • Align your items as usual

uncheck "Use Preview Bounds" when done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.