1

I'm using a crop tool (or marquee tool, then Image -> Crop) in Photoshop CS4. Immediately after cropping, the quality of anti-aliasing of Smart Object gets noticeably worse.

Before cropping After cropping

The blending mode of the smart object is Normal, and the opacity is 100%. I can flatten the image before cropping to preserve the quality, but it's just an inconvenience each time. Is there a way to avoid this loss of quality of Smart Objects when cropping?

closed as off-topic by Scott, Zach Saucier, Hanna, Vincent Sep 25 '15 at 11:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This appears to be a tech support question about fixing technology to work as advertised. Please edit the question so that it pertains to using technology to solve a design problem. You may want to check if it hasn't already been asked in Super User. In many cases, contacting the manufacturer is the quickest option." – Scott, Zach Saucier, Hanna, Vincent
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Thanks for the contribution and welcome to GraphicDesign! – Zach Saucier Feb 8 '15 at 20:42
  • Have you tried using a Layer Mask, instead of cropping? – Manly Apr 27 '15 at 19:26
  • I ended up using Ctrl+Shift+C to copy rendered pixels, then pasting them into a new document. – Amadeusz Wieczorek Apr 27 '15 at 21:46
0

This is a bug and does happen, I believe you can avoid it by making a smart object inside that smart object (with the same contents). Kind of annoying, but I believe that's how I handled it in the past.

Not the answer you're looking for? Browse other questions tagged or ask your own question.