0

I am trying to align a few text objects that have stroke applied to them using align all to the left. However, fist of all the font and font size used add an empty space in front of the text. And second of all, they don't align to the outer edge of the stroke. But to the outer edge of the font.

Is it possible to fix this?

I know of a potential fix. But I will have to turn everything into shapes. And I can't because I need to retain the ability to edit the text.

Thanks

  • 1
    You can copy and expand the copy. Then align the expanded copy and then add the text to the copy. – joojaa Feb 10 '15 at 6:53
1
  • select your text items
  • go to Effect->Path->Outline Stroke
  • hit Ctrl+K to bring up preferences and check "Use Preview Bounds"
  • Align your items as usual

  • uncheck "Use Preview Bounds" when done

0

Not sure if it's possible to align to the stroke of live text, but one quick workaround (which I use often) is this:

Place the live text where you want it. Copy/Paste In Front (Cmd/Ctrl-F), so there's a new copy in the exact same spot. Create Outlines on that text, then create a new layer, and move the live text to that layer (above or below your current layer, doesn't matter). Hide the layer with the live text. Now you can work with the outlined text as needed, but still have an editable version of the text you can go back to (and duplicate) at any time).

Not a cure-all, but may get you where you need to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.