I am trying to help with an .ai document I did not create. It has multiple layers and when they save as PDF, a faint black outline appears behind one of the images but an inch below it--just the outline of that image shape, not the shape itself.

Their concern is whether that outline, which is not intentional, will appear when printing. Obviously the best thing would be to figure how to remove/prevent it, before sending to printer.

I am a novice as you can tell, just cracking into Illustrator, and the complexities are many...

How can I try to fix this issue?

Do I need to fix it, will it show when printing?

Since the file contains lots of linked images, do I need to update every single link for viewing on my own computer before I can even try to recreate the ghost outline effect bug?


4 Answers 4


Depending on the PDF export settings you're using, it may be due to transparency flattening. This is often apparent when using X-1a, specified by many print providers. If you zoom in to examine, those lines generally disappear (and PROBABLY won't affect press output), but can still be annoying.

One way around this is to create a solid color-filled object (say process white or black), and place it at the very back. In most situations, it should resolve things. You may have to experiment a bit, to get the desired result.

This same process can be applied to InDesign, as well.


These are called "hairlines" and should not show during print. Sometimes these are due to using masks. Also changing your transparency quality settings illustrator can help eliminate these. If you still want to make certain that there will be no problems during printing simply export your Illustrator file as a hi-res TIFF.

Edit: After re-reading your post this is most definitely because you are putting images into Illustrator, which it is not meant for. I would suggest using either Photoshop or InDesign. Besides being the correct way to work, you will get better results and more control over images if you go this route.

  • 1
    ermmm... nothing wrong with placing raster images into Illustrator.
    – Scott
    Feb 16, 2015 at 7:14
  • As Scott said - Illustrator can be perfectly used with both images and vector objects. Feb 16, 2015 at 10:19
  • No… Not that you can't do it! I do it all the time for reference or if you're making a quick comp. But typically you should use each program for what were intended for. Feb 16, 2015 at 10:22
  • Yeah Henrik, it's not going to blow up, but illustrator isn't made for compositing images. For example, this is why InDesign has a panel for linked assets and illustrated does not. All I meant was—you'll get less issues if you're using many images and exporting for print if you use InDesign or flatten it as a TIFF. Feb 16, 2015 at 10:36

This happens to me in InDesign all the time. Even though the dark lines on the PDF do not print, it is a problem because PDFs are often distributed digitally. This solution should work in Illustrator also:

  1. Put everything that that is raster or has transparency (drop shadows, etc) on one layer.

  2. Turn off all other layers (text, logos, etc) and in Illustrator, open the AI file with Photoshop (In InDesign you will have to export as PDF first and then open in PSD). Save it as PSD and name it something you will remember (I usually add '-flatbg' to the name).

  3. Then you place the new PSD file on new, bottom layer in your original document (turn off old layer you just exported, turn on text /logo layer) and export as PDF.

  4. Whew, it is kinda a pain, but it flattens the background and now you can have a PDF that doesnt have the annoying black lines around certain objects. And the text/logos can still be editable if need be.


Choose another PDF print standard. In my experience it only occurs with PDX/X-1a:2001, not in PDX/X-1a:2003. Hope it helps somebody.

  • It would be nice if you could add some information about why there is this difference. Is it because PDX/X-1a:2001 flattens and PDX/X-1a:2003 doesn't?
    – Wolff
    Aug 31, 2020 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.