0

I am trying to make the path of the letters in 'hanwell' trim to/flush with the edges of the bridge illustration, so that the letters only appear in the gaps between the bridge pillars.

I have drawn a bridge using the pen tool and shapes, all parts of it are all on the same layer.

my bridge drawing

enter image description here

On a new layer I then expanded the type, selected both the type and the bridge, and clicked 'unite' on the Pathfinder Panel.

enter image description here

This nearly did what I wanted, but a strange horizontal line appeared, ruining it. Can anyone explain where this line has come from and how I can get rid of it?

To try and figure where this infuriating line was coming from, I tried getting rid of the text, selecting just the bridge and clicking unite, and it appeared again, which suggests to me that the problem is something to do with the bridge illustration and not the text.

enter image description here

As per the suggestion from a kind helper, I have also included what I get if I press show outlines (before I press unite) - strangely the rogue line doesn't show up.

enter image description here

  • I Should also have said, that i suspected it was something to do with the arch curves not being a continuous path from the pillars, so first tried to 'join' them which wasnt possible as the pilars are partle made from shapes so have no open end points, then i selected them all and made them a compound path but that failed too :( – melody Feb 28 '15 at 17:46
  • Rebuilding it should be pretty simple. I'll add how to doit in my answer. – Naty Feb 28 '15 at 17:58
  • Thanks Naty. I do need the detail on the pillars so not sure how I'll do that. Do you think my issue was caused by drawing the arches with the pen tool? Did you see my screen shot of what appears when i view outlines? – melody Feb 28 '15 at 18:09
  • I'd really like to understand what the problem is with the drawing i have - apart from anything else, i suspect i'll end up in this position again if i dont – melody Feb 28 '15 at 18:18
  • By seeing the images I can only assume what happened. Try to first of all unite the entire bridge to one shape and see what happens – Naty Feb 28 '15 at 18:38
1

The pathfinder functions don't always work well with open paths. The way I would solve this would be to try and make the archways into a closed shape without any open end-points.

To work with Pathfinder, I might make a copy of my entire structure and make it all into one shape - then I could use this copy to activate the Pathfinder functions and keep my original design intact.

Lets say I have a simple bridge made of paths like this: step one

The parts with black strokes are open paths, and the grey are closed shapes

Copy the whole thing onto a new layer and start messing with it to create the solid shape that we can feed into Pathfinder

I would then join these end points of the arches to a line above.

Select these two points: two points

and CMD + j to join them

joined

Once we've done that on each end we have only closed shapes to work with:

closed shapes

Which we can then Unite into one solid object:

unite

Then we can bring in our type and Unite this shape with it:

type Unite!

Or maybe I would use a clipping mask to hide the parts behind the bridge

clipped

with original

0

To see only the outlines of every object (even the ones that have no fill or stroke) go to view>outline. That way you can see what is bothering you. Here what you have to do is obvious, and you started doing it: take care of the bridge" and only then add the type. I think something wen't wrong with the original drawing of the bridge so the best thing would be to rebuild it.
Your shape is pretty simple, its only this repeating itself:
enter image description here

Here's how you rebuild the image fast:

enter image description here So just rebuild this little part with your pentool.

  • I Dont understand :( building the bridge in the first place took me ages so i don't really want to build again if i can in anyway avoid it. I think the problem is something to do with the end points of the arches. Is there a way i can join the edges to the pilars? – melody Feb 28 '15 at 17:53
  • @melody everything takes a lot of time when you havent done it. For example when we look at students that took 4+ hours to complete first cad assignment and ask them to redo it a year later they take about 5-10 minutes to do the same thing, a speedup of 24-48 times. So rebuilding something often takes way less time than you initially think. This is comparable as this is the kind of what cad people model (Draw). – joojaa Apr 2 '15 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.