5

I am laying out a book in Adobe InDesign.

Context: Since creating the original book document, I have changed the page size from 6x9 to 7x10. All my master pages are of the new size (7x10). (I have a feeling this relates to the problem somehow.) I have page shuffling turned on.

When a page shuffles from left to right or right to left (due to an earlier chapter changing the number of pages), the master page moves -- and is now misaligned with the page.

Before shuffle:

Correct alignment

After shuffle -- note how the master page no longer overlaps the real page correctly (which messes up a bunch of other things).

If I right click on the page and re-apply the master page, it's fixed. This is a pretty long document and I can't do that for all the pages. (I could one time -- but doing that every time a page changes is going to cause a lot of issue.)

Incorrect alignment

Edit

Added some more screenshots with simpler master page, where nothing is off the page. The same thing happens.

Before shuffle. Note how the master page correctly sits immediately on top of the actual page, with the correct boundaries. Before shuffle

After shuffle. Note how the master page is now misaligned with the actual page. After shuffle

  • 1
    possible duplicate of Indesign shuffling page -- It's not the objects that move.... it's your differing margins between left and right pages. Not really sure why you have a box around the entire page edge. – Scott Mar 3 '15 at 17:31
  • The inner and outer margins are different, but they're not that different to cause it to move by an inch. I don't believe it is a duplicate of that question. That question seems to be describing a different issue. – Gayle Laakmann McDowell Mar 3 '15 at 17:36
  • I assume the "box" you are talking about is the "show master overlay" option. As you can see, the master page is no longer on top of the page. The objects are moving, but only in relation to the master page. That thicker blue box is the master page. The thinner blue box is the actual page boundaries. – Gayle Laakmann McDowell Mar 3 '15 at 17:37
  • Well by default Indesign wants to keep elements on the page. You've got a rule stretching across the bottom of the spread it looks like. I bet if you remove the "Z-chapter", the box, and the rule across the bottom, nothing moves except the margins. – Scott Mar 3 '15 at 17:49
  • What rule? The thing next to the page number? Yes, I do have that... not following your point. The "Z-Chapter" is the name of the master page (that's not text on the page -- that's InDesign's "Show Master Overlay" option) and the thicker blue box is the boundary of the master page. Are you saying that I should remove the master page and then it wouldn't move? I mean, yes, but... that's kind of my question. I need a master page. – Gayle Laakmann McDowell Mar 3 '15 at 17:53
1

You're items are shifting due to the text and rule you have resting on and off the page.

enter image description here

Note the rule which is off the page bottom and extends to some bleed margin on the right (out of view). If this is a text frame with a paragraph rule applied, and the text is resting on the page, InDesign wants to keep the text on the page.

So when you shuffle pages....

enter image description here

That text frame gets moved to align the rule with the bleed on the left side.

InDesign is maintaining placement based relative to the page bleeds.

In your second set of samples the exact same issue exists. You've got objects off the page extending to bleeds. InDesign is merely trying to keep things on the page.

Note that the relative placement of everything else on the page is in alignment with each other. It is this bottom rule which is being adjusted when you shuffle pages, and causing everything else to try and maintain the same relative position to it.

I suspect that bottom rule extends to the right in your first example the exact same distance items are moving to the right when you shuffle pages.

  • What rule are you referring to? I really don't understand. That black line under Z-Chapter Start? The red line? The thick blue box? None of those are rules. The only rule I have is the black line above "Cracking the Coding Interview", which is well within the page boundary... isn't it? – Gayle Laakmann McDowell Mar 3 '15 at 18:26
  • The black line. Note how it is the item with a changing position seen by the left alignment with "Z-Chapter". I thought it was just the bottom of the page, but it's appearing as part of your selection as well. – Scott Mar 3 '15 at 18:27
  • If that's not the page boundary, then I have absolutely no idea how to remove it. Because it's not on my master page and even a brand new document has that. – Gayle Laakmann McDowell Mar 3 '15 at 18:40
  • It's not appearing as part of a selection, as far I know. It's the page boundary. When you click "Show Master Overlay", it shows the location of the master page and also the underlying document. – Gayle Laakmann McDowell Mar 3 '15 at 18:41
  • Perhaps the "show master overlay" option is confusing you? Here are some more images: link. The first image is without the "show master overlay" option on, and before shuffling. The second image is a totally blank document - note the black border is still there. The third image is after page shuffle, WITH "show master overlay" turn on. The fourth image is the exact same, but without that turn on. – Gayle Laakmann McDowell Mar 3 '15 at 18:47
0

( Ok, I "lied" in the comments on Scott's thread. I will answer.)

In your pre- and post-shuffle images, the center gadget is at the 3.5 inch mark.

Try changing the "zero point" of the document ruler to "top left" before shuffling.

Choose Edit > Preferences > Units & Increments (Windows) or InDesign > Preferences > Units & Increments (Mac OS).

Reference: Adobe Help Doc

  • Rulers appear to be set at 0 for the gutter, which is normal. – Scott Mar 3 '15 at 19:42
  • Rulers appear to be at 0, 0. When I go to Preferences > Units and Increments, the origin is set to Page (which I think is correct?). – Gayle Laakmann McDowell Mar 3 '15 at 19:51
0

I was having this same problem. Be sure the margins on your master pages are set to your desired specs, and that your "Primary Text Frames" (checked when creating the document) are set in those margins. In my case, I needed my outer margins to be wider than my inner to allow for notes and graphics in the outer margins. Simply setting the master text frames to my desired dimensions would not make them appear correctly on the pages as I added/deleted pages (they'd appear in the wrong places on all subsequent pages). Only when the master page MARGINS were set correctly (the magenta box in the image below) did my document flow correctly when pages were inserted/deleted mid-document.

enter image description here

  • This sounds like a different issue from the one Gayle is asking about here. It sounds like in your case, the text frames were misaligned on the pages, whereas in Gayle’s case, it’s the master pages themselves that were misaligned with the document pages. – Janus Bahs Jacquet Jan 8 '18 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.