8

I am building some kind of mockup for business card and while i was trying to create the looks like cards are on top of each others i used smart object to easily change look of business card on all the layers but the problem is that on rotation the photoshop really made a hard cut lines of the layers.

Here is an sample image what it looks like enter image description here

I tried to change few settings that i found online under Preferences > Image Interpolation and it works kinda, different settings gives different smooths, but the smoothest gives a hard blur on the lines.

I also tried to convert it to 3d object as someone suggested and render it, this works as a good solution even when rendering is not done completely, but it really takes a lot of time to render. For my current file it would take 8 hours to render.

So is there any way to smooth out those lines a bit in some way ?

  • Welcome to GraphicDesign! Let us know if you have any questions – Zach Saucier Mar 8 '15 at 19:03
  • 2
    I did a test here and my results are much smoother than yours and much more realistic looking. Are you sure Image interpolation set to "Bicubic Automatic" (which is the default) doesn't work for you? In a real black object with a very thin white border if you look at it from far enough it will appear blurry. – Luciano Jun 10 '16 at 9:12
1

I realize that this is an old stack but seeing as it is still lacking an answer other than, "I wouldn't worry about it", I thought I would go ahead answer the question.

I am assuming that by straight and clean lines you mean lines that you can rotate off axis without causing the line to jut ("stair step" effect).

The only way to achieve these "smooth" lines that you desire within the digital realm is with vector based graphic images and editing tools versus raster based graphics. You can get more details and how this specifically applies to your query and the best ways to implement it into your workflow elsewhere within the Graphics Design Stack Exchange and on the web but the long and the short of it is; Vectors are polygon "points" that can be placed on any point on any axis in the field, so they arent subject to grid patterning like pixels are, allowing for smooth radii (lines) at any angle, as they are nothing more than several points laid out in a row.

0

Do you need to display the image in a large resolution or are you just using it for an online portfolio? If that's the case, I wouldn't worry about it. Make sure you are working at a large resolution, scale it to a size that is more appropriate for the web/whatever platform you are displaying the image on, and it should look fine.

If that's not the case, I would consider creating your own stock image. It's probably worth the trouble anyhow.

Edit: I'm not sure if this will do anything, but have you tried rasterizing the smart object to see what it will look like?

  • I am using it for a portfolio but the images are in 1600 resolution so the hard edges are visible too much. I do created image from the scratch and this is a smart object rotated to display business card design. Whenever i turn it around it gets hard edges. This sample is rasterized smart object and than exported for web in jpg with quality 80. – Aleksandar Đorđević Mar 17 '15 at 18:33
  • The resolution won't matter much if the images are not big enough - by the looks of your screenshot, they aren't; a 1px line in an image with 1600 DPI will look really tiny. – Luciano Jun 10 '16 at 9:15
0

It's not the best solution but have you tried to apply a Blur Smart Filter to the Smart Object and use the correspondent mask to smooth it out? It won't create a sharp image but at least will hide some of those imperfections.

0

First, rotate object and then apply outline.

0

I really do not understand the issue if the object exported/saved as jpg or png, or whatever final option you export to, still looks OK. There could be two reasons the issue occurs.

Scenario 1: Display Video Issue

Probably the jagged edge is cause by a low pixel density display, check if you can set the optimization preferences to use the GPU of your graphic card if you have one that support this option. Again, this only works if you have a graphic card that have GPU optimization and the problem is your display pixel density issue.

Scenario 2: Embedding, Converting to Smart Object and Resizing

If you embedded the object into the working file, convert to smart object and then change your mind and increase the resolution of your file. The smart object is still set to the size that was originally created, so if you change the resolution of your file too much, the Smart Object will show artifacts.

Go to the layer in question right click on it and edit content. Resize the file to match the new resolution and save. When returning to the working file, you might need to readjust position and location of the layer.

If by resizing the object generate artifacts then I would suggest to import the file into the working file again.

0

Mystery solved! Edge quality on transformed smart objects has often been less than ideal and I couldn't figure out why. The solution seems to be to make the smart object not much larger than the size it will be after transformation. So don't use a 2000 pixel smart object for an 800 pixel area, the edges will start to look jagged, particularly when rotated, distorted etc.. Place your 2000 pixel artwork in a 825 pixel smart object then transform it for much better edge quality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.