4

I am using Photoshop CS6.

Recently when I try to type in our local language "Gujarati" via Google Input tools (I tried without Google tools also, with Gujarati fonts), the typed text not showing joined word and characters correctly.

This is how it looks in Photoshop:

enter image description here

It is working correctly everywhere except Photoshop. This is how is should look (typed in Chrome):

enter image description here

To better understand my problem, there is a similar question on Stack Overflow. That problem is for Android and my question is for Photoshop.

8

I don't know if this works for "Gujarati", it does for other languages:

  1. Make sure you have ligatures turned on:

    enter image description here

  2. Check the features of your own language:

    enter image description here

  3. In preferences, check you have the right mode (if it's not after changing it restart Photoshop):

    enter image description here

| improve this answer | |
  • I'm facing the same issue and unfortunately the said 'ligatures' options are disabled. – NBaua Jan 14 '18 at 12:18
  • Hi Friend I'm facing same issue and I have follow the steps. The Middle eastern features is disable you can see it by this link 3emperor.com/Screenshot_5.png. I have also tried to change it from edit->preferences->type.. 3emperor.com/Screenshot_6.png but I not get the result. Please help. – Rushil Pachchigar Feb 8 '18 at 16:34
3

QUICK SOLUTION

Here's the quick solution I've found (I am using Photoshop CC).

Install the Noto Sans Gujarati fonts to your system and then follow these two simple steps.

  1. Go to Preferences > Tools > Middle Eastern and South Asian

    Select Middle Eastern and South Asian

  2. Write anything on Google Translate or any other document like a Word file, then copy the entire text to Photoshop and make sure you've selected Noto Sans Gujarati as displayed in this screenshot:

    Select Noto Sans Gujarati

| improve this answer | |
  • Is this font commercial or free? – Mensch Feb 5 '16 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.