2

Simply, I am trying to bring an image made in Photoshop into Illustrator for the purposes of creating a vector image for a t-shirt design.

The image has only one layer and contains transparencies. I have tried saving it as png, pdf, psd, eps. I have tried several methods to bring it in; simply open it normally, copy/paste, "place", drag/drop... all with each type of file mentioned.

But nothing worked as expected. Every method yields the same result - the background in illustrator is solid white and all transparency is lost.

Note: Yes, the transparent grid is visible, the image is definitely not transparent after it is brought into Illustrator.


I can get my transparency back by tracing with the ignore white option selected, but unfortunately that's not an viable solution as there is white in the image itself that needs to be retained.

Any suggestions would be greatly appreciated!

  • There is an issue with your image, it's maybe damaged. Open it in Photoshop, save for web (png 24) again, place it to illustrator, as I've explained in my answer, works. – p2or Mar 21 '15 at 14:58
2

Copying to the clipboard in photoshop with Ctrl/Command+A followed by Ctrl/Command+C, switching to illustrator and simply paste it into layer with Ctrl/Command+V seems not always maintain the transparency of the image.

In this case go to File > Save As or File > Save to Web and choose file format which supports transparency like .png or .tiff and place it to your illustrator canvas.

enter image description here Transparent layer in Photoshop

enter image description here PNG File placed to illustrator canvas

Note: Illustrator's backdrop isn't transparent by default. You can enable transparent backdrop by pressing Ctrl/Command+Shift+D. As alternative you can draw a rectangle to the first layer and set it to red. Create a new layer, paste your image into it and check the result.

  • Thanks for the reply, but "I have tried..copy/paste" I'm afraid that was one of the first ways I tried. No luck - this method does not retain the transparency. – Brad Mar 21 '15 at 14:10
  • @Brad Answer updated. You are right - I've created a text in photoshop and couldn't paste it with full transparency. I've tested png format and it works as expected. – p2or Mar 21 '15 at 14:35
  • Thanks again. There must be something peculiar about my image that I am simply missing. I have tried png (that was my first attempt) as well as a few other file types. PNG did not retain the transparency for me I'm afraid. Maddening. – Brad Mar 21 '15 at 14:40
  • @Brad Images added. You could add a test file to your question than I can play with it, but as you see it should work. – p2or Mar 21 '15 at 14:46
  • I added image to my initial post. Thanks a million for the efforts. – Brad Mar 21 '15 at 14:54
2

I just solved this problem for myself, and for me, it had to do with the color mode I was using in Photoshop. In Image> Mode > my image was CMYK instead of RGB and my background was white every time I tried to copy/paste or import my png file to illustrator. As soon as I converted my Photoshop file to RGB mode I was able to export my png file and import it without a white background showing. Hope this helps!

0

Assuming there is nothing wrong with your image, you should be able to just do Place and in the dialog make sure the Link button is checked.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.