1

I had a heck of a time getting transparencies from Photoshop to Illustrator. A member here, "poor", had my solution. But the problem wasn't over it seems.

The image I had been trying to bring into Illustrator appeared with all of the transparent areas filled with white. The reason I wanted to get it into Illustrator in the first place, to trace and create a vector. Well, I did a trace and all of the previously transparent areas...filled with white. Right back where I started.

I cannot simply select the white and delete, as that process selects all white indiscriminately, and I have white in the actual image that needs to stay. Is there really no way to work with transparencies and tracing in Illustrator? I'm sure there must be, but I'm at a loss. How does one do the trace process and create a vector, without having previously transparent areas filled in with white? Thanks again for any help.

About the image; It's 10 solid colors w/transparency (no variance or gradations in any of it), png 24 ("saved for web"), oh, and I'm using CS6. thx

  • Select rhe transparent option. Or expand ungroup and delete – joojaa Apr 23 '15 at 4:47
  • Ah the option is called ignore white – joojaa Apr 23 '15 at 7:43
1

Unfortunately Illustrator cannot distinguish between transparent and white when tracing.

But there is a workaround: set your transparent areas to a solid key colour, and after tracing, delete the key colour.

Here's how:

  1. With your artwork in Photoshop, create a solid colour behind the artwork to be traced (with Layer > New Fill Layer > Solid Color ). Choose a colour unlike any of your other colours, and, of course, not white. There is now (temporarily) zero transparency in the artwork.
  2. Save the file (PSD is fine). Import into Illustrator.
  3. Trace the imported artwork, ensuring 'Ignore White' is unchecked.
  4. Expand the trace so that you can select all the key colour elements (and don't do it the hard way, use the Select > Same > … functionality) and delete.

What remains is each of the 10 intended colours, and nothing else.

-1

Ok. I think it might be a file format issue. Make sure you are exporting a PNG file from Photoshop. Once the file is created, then simply place it in your illustrator art board. It should work.

  • Unfortunately, I don't think so. In my experience transparent areas are always converted to white, unless you tick "Ignore white", in which case all white becomes transparent. – MG_ May 23 '15 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.