0

I'm a beginner-to-intermediate user of InDesign.

I am unable to apply my Paragraph Style to a number of my text boxes. I have tried holding Opt/Alt while choosing the PS with no luck. I have also checked for local overrides and character styles, and there appear to be none. The fly-out menu from the Paragraph Styles menu is almost all greyed-out, so it won't let me select the Clear Overrides option.

However, when I double-click the text box to go into the frame, I am able to select the text directly and then apply the paragraph style to it directly inside the frame. This seems weird; I'm hoping there's a way that I can just select the frames normally and apply a paragraph style as usual.

The text came from a Word document that was flowed into each chapter, if that gives any help.

  • If your text flows/links to additional boxes, you can't apply a style via selecting the boxes. You have to apply the style directly to the text. – I usually do a Select All on the copy, then apply the style. – Rsiel Mar 23 '15 at 18:27
  • I confess I have never heard of applying a paragraph style to a frame. Why wouldn't you apply it to the text? It's not a frame style. – Lauren Ipsum Mar 24 '15 at 10:13
3

I made this an answer just to be kosher.

If your copy is contained within a single box, you can apply a text style to that box.

If your text flows/links to additional boxes, you can't apply a style via selecting the boxes. You have to apply the style directly to the text. – I usually do a Select All on the copy within the box, then apply the style.

You will also notice that if your text box flows/links and you have it selected (the box), your character and paragraph pallets will be grayed-out.

0

Only one way to do this properly:

  • forget about selecting text frames, that is not going to work
  • double click the text to go into edit mode
  • hit Ctrl+A to make sure everything is selected if you are working with threaded frames
  • in the 'Paragraph Styles' panel, right click the name of the style you need to apply and choose the 'Apply + Clear Overrides' or the 'Apply + Clear All' option, which will clear out any leftover Word formatting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.