1

When I draw a rectangle in Photoshop, it does not place it on any layer. This seems like unusual behavior.

  1. Create a new document
  2. Unlock Layer 0.
  3. Click on Layer 0 so it's selected.
  4. Draw a rectangle in my document.

At this point there is still only Layer 0 in my layers tab. If I make a new layer, then delete Layer 0, the rectangle is still there.

What am I misunderstanding about Layers in Photoshop? In Illustrator this would have added a rectangle to the selected layer.

3

With a Shape Tool selected change the drop down menu in the Control Bar to something other than Path.

enter image description here

If this is set to Path you merely get, well... a path. No layer will be generated for a path, only a path will be created (and will be visible in the Paths Panel).

0

It depends what tool you're using in Photoshop. Could you specify what tool you're using to make the rectangle?

If you're using the pen tool your path will still be there when you delete a layer. If you're trying to add a stroke to the path right click on the path you created and just click stroke path. (I'm also going to assume that's probably what you're using since that's what I myself would use in illustrator to make that..) You should get menu giving you a list of tools, I would just pick the brush tool if you're trying to create a stroke. You can also edit what the stroke looks like by changing to color and the type of brush and size of it before you make the stroke while using the brush tool.

If you're trying to apply something like a fill you can also just right click the path and click fill path.

I don't think you're misunderstanding how layers happen to work it's just tools you might have used in Illustrator behave differently in Photoshop.

0

Create a new Layer Select Rectangular Marquee Tool (Shortcut Key M) Draw Rectangle Goto Edit Click Stroke Adjust Color and Stroke size Click OK

0

this was bothering me for at least 30 mins. lol.... after hovering the mouse cursor over a few options i found out. turn on filter for shape layers in the layers window on right. it will be at the top. looks like a square with smaller squares on each corner

  • 2
    Welcome, but it's already mentioned in Scott's answer, please do not add an answer with repeated info. Take a look at the tour and How to Answer to get used to how the site works. – Luciano Jan 31 at 16:46
  • @Luciano - this new answer is not the same thing as Scott, who quite correctly directed OP to consider what happens when one sets the shape tool to generate a path: it creates a path available in the Paths Tab, but remains unseen in the Layers Palette. He did not direct OP to change any settings in that Layers Palette, which is what this incorrect answer erroneously does. Jeremy, please re-read OP's question: your proposed answer is not a match for their condition; they're creating a shape, and not "seeing it" in any layers - because they created a path. – GerardFalla Feb 4 at 16:35
0

make the following settings this worked well for me.

select shape and no fill (/) then change the stroke other than black/white e.g. Red and set the stroke usually less than 0.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.