3

When I store transparent images with shadows as .png I have filled areas instead of soft edges. It seems like it is a saving/compression or whatever problem because the .psd is in photoshop really fine and the same .psd worked for a transparent when he created the transparent .png.

This is how it looks as .png: http://puu.sh/gZdrh/8b8fc16424.jpg

enter image description here

This is how it looks in photoshop (red background): enter image description here

http://puu.sh/gZdAf/6991e89fc4.jpg

What is causing this problem? It's a RGB / 8bit .psd

  • 1
    How are you saving? Are you going to "file-save for web"? Have you made sure that transparency is checked? What happens when you open the PNG that you just saved back into Photoshop? Are you saving as PNG-8 or -24? Can you post a screenshot of your save for web options? – AndrewH Apr 2 '15 at 21:19
  • 1
    ".....when he created the transparent .png" Who is "he"? And did you ask "him"? – Scott Apr 2 '15 at 21:59
4

Blending modes do not translate to PNG images. I would guess that you've se the shadow to Multiply within Photoshop.

Your shadows need to be set to Normal for the blending mode. This may mean you need to better mask the shadow layer or remove the shadow entirely and recreate it without the white areas.

  • This problem wouldn't happen if you did an apply image and turned off the visibility of the bottom layers, right? – AndrewH Apr 2 '15 at 22:08
  • If you turn off bottom layers, you'll see the white. So no, that won't work either. If you don't want the white pixels in a PNG you have to remove the white pixels as far as I'm aware. – Scott Apr 2 '15 at 22:09
  • What I am saying is he clearly has a transparent background (See red background). So there isn't "white pixels" in the background or part of the layers. I am under the assumption that if you apply image to everything he made (not including the red background layer). Then he shouldn't have to worry about the blending modes because the layers would be flattened into one layer with a normal blending mode (if he chooses the right options in apply image). – AndrewH Apr 2 '15 at 22:15
  • 2
    My assumption is the red background is behind the white and black shadow layer and the shadow layer is set to Multiply or Darken. This is the most common set up for a shadow layer within Photoshop. Removing (or hiding) the layers below the shadow layer would make the white and black pixels of the shadow visible because there would no longer be any inter-layer mixing and a white layer set to Multiply against a transparent background would still be visible as a white layer. – Scott Apr 2 '15 at 22:17
  • 2
    Essentially the PNG is showing the actual shadow layer as it currently is. The Photoshop tricks (blending modes) to make the white vanish are not supported in the PNG format. – Scott Apr 2 '15 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.