2

When I create a shape that overlaps with itself, the part that overlaps is subtracted.

How can I prevent this ?

enter image description here

EDIT:

Here are pics with step by step and full screenshots:

Step1 - the path starts to overlap itself: http://imageshack.us/f/62/screenshot20111219at102.png/

Step2 - I close the path: http://imageshack.us/f/11/screenshot20111219at102.png/

Step3 - I use the path to create the shape: http://imageshack.us/f/641/screenshot20111219at102.png/

3 Answers 3

3

I'm gonna say that that's just the way Photoshop is designed to behave, and there's really no getting around it other than to create a non-overlapping path. The add to path area menu will only affect the way additional paths are added to the existing one.

So you're gonna need to divide your path by adding anchors where the outline intersects, delete the overlapping areas, and then rejoining the pieces.

Or you can just divide it into 2 separate paths and let the add to path option do the rest.

2
  • Exactly! There is no additional paths added, just the first one. In a lack of an answer that gives a solution, I'll mark this as the good one.
    – Nicu Surdu
    Dec 19, 2011 at 15:19
  • 1
    I had the exact same issue in Gimp, and ended up just duplicating the path and removing half of each, so I ended up with two overlapping separate paths. Then I just filled both of them independently to get the final filled shape.
    – Nyerguds
    Dec 27, 2014 at 16:50
2

Make sure you have this "Add to path area (+)" option enabled...

enter image description here

Little information about other top options :

enter image description here

4
  • I've tried that, still didn't work. I draw that path with the pen tool, and then add it as a mask to a solid layer. I take care every step of the process for the mode to be set to "Add to path area" but still the overlapping areas of the shape are subtracted.
    – Nicu Surdu
    Dec 19, 2011 at 7:43
  • might be something else is there i did the same but it worked for me very well...try once again restart your ps. hope this will work
    – Jack
    Dec 19, 2011 at 8:01
  • 1
    if possible post your PS document full screen, might be we will find something which should not be "ON"
    – Jack
    Dec 19, 2011 at 8:05
  • I've added an EDIT with step by step instructions of how I proceed and full screen shots. Maybe I made my self unclear: there is only one path there, not multiple ones that overlap.
    – Nicu Surdu
    Dec 19, 2011 at 8:42
0

I had the same problem but managed to solve it by: exporting the path into Illustrator. Select the shape and "Divide" it using Pathfinder. Then select the paths again, but this time using the Direct Selection Tool and selecting the outline and 'negative' areas (not selecting any other 'loop' centres) and "Unite" - this will give you your proper shape outline. Then, if necessary, select everything and make a compound path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.