3

Relative novice here. I can't work out why InDesign is causing my leading/space between paragraphs to stop working when I float a wrapped image beside it.

This first screenshot shows the problem in action. The object image on the right has 2mm left offset. The text on the left has three paragraphs, split after the words "straightforward" and before "Don't delay". But there is barely any paragraph spacing between them.

Bad one

When I move the image out of the way temporarily, the leading between paragraphs restores back to the usual height. This only happens when I move the wrapped image out of the way. There are no paragraph rule overrides etc. and I can't pin down why it's doing this.

Good one

Any ideas? Thanks!

  • What do you mean with leading? – Viktor Aronsson Apr 20 '15 at 15:38
  • @ViktorAronsson sorry, I think I'm getting confused between paragraph spacing and leading. I mean the vertical space between each paragraph shrinks when the image is floated alongside. – Jack Apr 20 '15 at 15:54
  • How is your paragraph spacing created? Are they just extra line feeds or are you using the space before/after options for the paragraphs? The latter is preferred. – Scott Apr 20 '15 at 16:15
  • @Scott no extra line feeds, I am using a single return key press to separate paragraphs (and headings). I am not using any space after paragraphs, but instead am aligning the first line of a paragraph to the baseline. – Jack Apr 20 '15 at 16:39
  • @Scott just realised that's what's causing the problem! It just so happens that the number of lines those paragraphs equal (3/4/4) happens to make it align equally with the baseline at my chosen font and leading sizes. – Jack Apr 20 '15 at 16:43
1

After playing around some more, I worked out that it just so happens that the number of lines those paragraphs equal (3/4/4) happens to make it align equally with the baseline at my chosen font and leading sizes. I had configured the paragraphs to align to the first line of the baseline which was making these paragraphs look odd by coincidence. Shortening to 2 lines made everything look normal again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.