I created an animated banner ad in Photoshop CC and need to save it as gif.

I used Timeline/Motion. When I "Save for Web" the second box from the top is set to "GIF".

I click "Save" and the only option is to save as html. I'm saving to format "HTML and Images." If I save to "Images" only, I get individual screen shots, not animation.

And yes, I have loop set to "Forever."

Is there a way to save this as Gif? Or do I have to redo it all in Adobe Flash? (which is grainy)

  • Could you take a screenshot of the save settings? When I save as HTML and Images, I get an html page and an images folder which contains a single animated gif looping forever.
    – KJP
    Commented Apr 21, 2015 at 7:01
  • 2
    Sounds like you could be configuring something incorrectly, it would definitely help to see what settings you're using. I just created a looping GIF, saved as "Images Only" and it works perfectly for me. One single .gif file that, when opened in my browser, loops.
    – Manly
    Commented Apr 21, 2015 at 15:55

6 Answers 6


To answer your main question: yes, you can save an animation as a gif from Photoshop CC. You won't need to rebuild it in Flash.

To echo others, it sounds like you might have some misconfigured settings somewhere or possibly your animation isn't built properly. Posting more detail would help. I've tried to reproduce your problem and can't seem to come up with what you've described. In the meantime, here is the process for creating a GIF from Photoshop CC:

First adjust your frame or timeline animation (either type of animation should work, though I prefer the control of frames when making a GIF). Then select File > Export > Save for Web (Legacy)…

Animation of navigating Adobe Photoshop CC menu to save animated GIF: File > Export > Save for Web (Legacy)…

In the Save for Web dialog, ensure your export, compression, and looping options are set how you want and test the animation playback.

Testing animation playback in Adobe Photoshop CC in Save for Web dialog

Select Save and choose your save options. There is no need to select either of the HTML options if you are just exporting an animation to GIF.

saving a gif via the Save for Web dialog in Adobe Photoshop CC

because there are several distinct steps involved in creating an animation and exporting it as a .gif file via Photoshop, it's important to test your animation's playback throughout the process.

Testing along the way will not only ensure that you get desired results in you final file, it will also help you know which part of the process to troubleshoot if something turns out wrong.


Save it as it is. It will output assets, one of which will be the GIF. Just check where the files are getting saved.

  • 2
    And why and how can that be proofed? For a valid answer your comment is too short! Please explain better and welcome to GD.SE!
    – Mensch
    Commented Apr 22, 2016 at 18:34
  • This answer would have been better as a comment. Perhaps add some graphics to show what you mean.
    – McIvor
    Commented Nov 30, 2016 at 12:44

I've made a few gifs in photoshop and haven't run into this problem. I've attached three images that show the process I've used to make .gif files.

  1. Photoshop environment with frames as layer and the animation toolbar Photoshop environment with frames as layer and the animation toolbar
  2. Save for Web and Devices dialog with the settings I use Save for Web and Devices dialog with the settings I use
  3. Save dialog that pops up after pressing "Save" Save dialog that pops up after pressing "Save"

Maybe this can help point you in the right direction? I'm guessing it's probably just a setting that needs tweaked. Hopefully this can help.


I had the same problem and it took me forever to figure out. You may have GIF settings selected that are set to save as HTML. Delete the settings. See the arrow below. Then make sure that output settings are for Images Only as mentioned earlier.

enter image description here


When you're exporting and it says "HTML" - change it to "Images Only" and it will output GIF.


These guys don't have the whole picture - Check your output settings on the top right dropdown and be sure that your selecting 'background' instead of HTML below the settings dropdown.enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.