The issue I am struggling with can be described by the following steps:

  1. Create new RGB document.
  2. Ensure that it's color mode is really RGB and not CMYK.
  3. Ensure that Edit/Color Settings are set to Monitor Color. Also, that under 'Assign profile' it is set to 'Don't Color Manage This Document'. The point is that I don't want any color profile or gamma correction at all, I would like to have the same numerical values on any device. Don't care about printing either.
  4. Draw a rectangle with a solid color e.g. 62,185,203.
  5. Verify that it is seen as 62,185,203, I use OSX's built in Digital Color Meter for this (setting 'Display native values). It appears correct.
  6. Now, I'd like to export to a PNG. Select Save for Web, use PNG24. Now, in the preview window I see a different color with Digital Color Meter (and with my eyes also): 0,189,206.

Same results with both CS6 and CS5, on two different machines. I verified there is no color profile in the resulting png (which is what I want, but the colors are off), so tools like pngcrush or ImageOptim do not help (tried already).

I realize that there are similar questions on Stack Exchange already, but the accepted solution for those other questions seems to be to turn off color management, which I already had.

Thank You for your help!

| improve this question | | | | |
  • 2
    Why would you expect that your OS is not color managed? I would never turn color management of for any reason that would be just stupid. Images are never non-color managed, what you get is a random result instead. – joojaa May 2 '15 at 11:32
  • It is certainly possible to display a non-color managed color (that means, using display native's color) on various OSes from a user level application, and to display pngs with native rgb values (color profile stripped). I would just like to see the same colors in Illustrator, and after exporting. – Zsolt Szatmari May 2 '15 at 11:48
  • Its possible but its random. It has no meaning. The problem is that non color managed means one of 2 things not defined and sRGB. So depending on the reader you have different results in different applications. that means, using display native's color unfortunately it hasn't meant that for a long time. – joojaa May 2 '15 at 12:09

Lack of color management does not mean the image is not managed. No color management means the image is set to sRGB*. It would be MUCH better to color manage it with your systems settings or set to sRGB. You'd get the same result and it would actually mean something to other devices (that now will proceed thinking it is sRGB and color manage accordingly)

Anyway if you really intended the system not to manage you need to tell it you dont expect the image to be sRGB. Save for Web will by default assume your doing sRGB images. Next to the preset box in save for web dialog there's a menu, in it check that the option convert to sRGB is not checked.

Please note that this will result in a image that might or might not do what you want **. The end result is unpredictable. This is because software fall in 2 camps. Those that assume unprofiled images are sRGB and those that do not. So your image now displays in 2 ways. Neither of which do what you think they do on other systems.

As a alternative approach set the document to color manage, but set it to sRGB then no conversion happens.

* This is the definition today, has been for more than 10 years now.
** Most likely what will happen is you think it worked, but then down the line you notice it didn't. That is unless your suing a highly custom production pipeline.

| improve this answer | | | | |

When creating new Illustrator documents and targeting devices, create them with sRGB color space. For further understanding about color spaces, see e.g. here: https://fstoppers.com/pictures/adobergb-vs-srgb-3167

Assuming you already have an Illustrator document with no color management, add it:

  1. Under Edit/Color Settings, select Europe Web/Internet. This should entail the sRGB color space. Also select Missing Profiles: Ask when opening.
  2. (Re-)open the document. It will detect missing profile and pop-up a dialog. Assign 'Display' here since you've been working with Display rgb values.
  3. Colors should appear correct.
  4. Select Save for Web&Devices. There, if optimization is turned on ('Art Optimized'), which is necessary for proper antialiasing, the Preview shows wrong colors. This is because the color values in the file and the working space are still different and for Preview purposes the application is not doing all calculations properly. Don't be surprised about this, just click Save.
  5. Colors in the exported png should appear correct.

(joojaa's comment was great help in figuring this out, Thanks!)

| improve this answer | | | | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.