0

When I press the Printscreen key and the paste into Photoshop, colors are quite different.

I tried to do this with a RGB colors document (8, 16 and 32 bits).

How can I ensure Print Screen will capture accurate color when pasted into Photoshop?

  • 2
    nothing, your color profiles just dont match – joojaa May 3 '15 at 16:02
  • Sure, but this is extremely inconvenient since I often do that and now I just can't. How to solve the issue? – drake035 May 4 '15 at 12:00
  • This question should be closed as it belongs on Super User because it has nothing to do with graphic design but rather a program (or system) malfunctioning. It's also very hard to answer because not much detail is provided at all – Zach Saucier May 11 '15 at 19:45
  • Hi drake035. I've edited your question to keep it more on topic. If you feel my edits were incorrect, please feel free to edit yourself. Thanks! – Scott May 11 '15 at 20:11
  • Is your monitor properly calibrated? Are your color settings within Photoshop set properly? – Scott May 11 '15 at 20:15
2

If your system or your application uses colour management, the RGB values of colours are converted from their original colour profile to the installed colour profile of your monitor when the colours are shown on your monitor.

Typical print screen functions make a copy of the entire screen as it appears on your monitor; i.e., the colours get the converted RGB values that correspond to the installed colour profile of your monitor.

Therefore, if you paste the screenshot into a new Photoshop image, the numerical RGB values are the converted RGB values (not the original RGB values).

You can test whether this case applies to you:

  1. Create a Photoshop image with a suitable colour profile and fill it with an extreme colour (e.g. electric cyan).
  2. Press Print Screen
  3. Paste the screenshot into a new Photoshop image and compare the RGB values of your colour.
  • Wow, never paid attention to "color profiles". Just created new document (color profile is Working RGB: sRGB IEC61966-2.1), filled it with cyan, hit printscreen, created new document and pasted it: colors don't change in that case. Anyway is there a solution to my problem? – drake035 May 3 '15 at 17:52
0
  1. Calibrate Your Display (monitor). How you do this depends on your operating system.

  2. Adjust the Photoshop Color settings correctly if needed.

    • In many instances configuring the Photoshop Color Settings (Edit > Color Settings) to North American General Purpose 2 will provide a good base setting for color profiles. You may wish to alter this though based upon your specific working environment.

Most likely you get overly inaccurate color when using PrintScreen and pasting into Photoshop because your display is not properly calibrated. A poorly calibrated display isn't accurately showing colors so Photoshop is just pasting in what the screen states is the color profile to use. If no profile is specified (uncalibrated display) then Photoshop guesses. And being a dumb computer, that guess isn't always correct.

In an image with no embedded color profile Photoshop "throws in" whatever is specified as your working RGB profile in its color settings. If you calibrate the display, there will be an embedded color profile. In that instance Photoshop reads the numbers and converts those numbers to your "working RGB" profile setting.

Adding a profile to an image without one can often result in undesired color changes. Converting from an embedded profile to another profile yields far more accurate results.

-2

You can setup color management this way

Edit -> Color Settings (Shift + Ctrl + k)

under Color Management Policies set everything to Off like below

RGB: Off
CMYK: Off
Gray: Off

by turning the color management Off this way, It Turns off color management for newly created documents and for newly opened documents that have embedded color profiles different from the current working space. Hope this helps thanks!

P.S: I have answered this question considering photoshop CS4.
since you have not mentioned the version of photoshop you are using.
  • Dont set color management off! Set it to sRGB. Off does not mean what you think it does. – joojaa May 14 '15 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.