1

I've created a document that's got an elaborate layout of a bunch of text boxes. When I export to PDF, open the PDF in Preview, select all and copy out to a text file, the order of the text boxes is seemingly random. How can I control this?

I tried connecting all the boxes with text threads and using frame breaks. I've tried fiddling with the Articles palette, the Structure feature, and the Tags. I've tried exporting the PDF as Print and Interactive, and I've tried checking "Create Tagged PDF" and "Use Structure for Tab Order", and nothing has changed the order of the text.

How can I get the text in the exported PDF to flow the way I need? (I'm using InDesign CS6, if that makes a difference.)

  • Wouldn't it be quicker to just copy text in Indesign and paste into a text editor? – Scott May 20 '15 at 0:27
  • @Scott That would be SO much easier. But not the case I'm worried about. I'm sending this PDF out, and I need for it to be bullet-proof, including having the text be able to be cut'n'pasted out. – Alesh Houdek May 20 '15 at 0:34
  • 1
    Have you tried Acrobat or Reader? Preview is really not the best app to use for real-world PDF workflows. Of course with Acrobat you can just save as text. – Scott May 20 '15 at 0:34
  • @Scott My goal is to create a PDF that I can send to people that will be as perfect as possible, meaning they can cut and paste text from it with whatever application they have, whether it's Acrobat, Preview, or even Google Chrome. Are you saying I should use Acrobat to somehow re-arrange the text boxes in the PDF without changing its appearance? Is there really no way to do this correctly from inside InDesign? – Alesh Houdek May 20 '15 at 0:49
2

Try rearranging the layer order in the Layers panel. For example, if the layer order of your text boxes looks like this...

"jumped over the"

"lazy dog."

"The quick brown fox"

...then this is probably what's causing your problem. The position of the objects doesn't matter; the layer order does. You can do this in the Layers panel (by expanding each layer and dragging them up and down). Otherwise, here are the shortcuts to change the layer order of selected object(s):

Ctrl + [ (move up 1)

Ctrl + ] (move down 1)

Ctrl + Shift + [ (move to top)

Ctrl + Shift + ] (move to bottom)

  • Nope. I've re-arranged all the layers, but when I re-export the pdf, select-all, and cut'n'paste into a text file the order is still scrambled! – Alesh Houdek May 20 '15 at 0:06
  • I think you may mean stacking order not necessarily "layer order". They are different. @AleshHoudek realize layers and stacking are two different things. Although this answer mentions "layers" the shortcuts given alter stacking order of text frames on the same layer. – Scott May 20 '15 at 0:32
  • @Scott Thanks for your help! I've got the layer expanded in the layers pallet and I'm dragging the items representing the text boxes into the correct order. Is that what you mean? Because (as optimistic as I was!) that turned out not to have any effect on the order of text in the PDF. – Alesh Houdek May 20 '15 at 0:48
0

One possible work-around might be to use 1 large text box that contains all your text.

  • Hey Phil, welcome to GD.SE and thanks for your answer. As with a lot of your answers, you seem to be very short and to the point. While in some cases that's good, we tend to prefer thorough, well-researched answers that have value for later visitors as well. Not in the last place, your short answers each trigger a flag for us mods to look at--and we're somewhat lazy :). So please consider elaborating a bit more in your answers, even if it means posting less of them. Helps the OP, and gets you more upvotes! If you have questions, take a look at the help center! – Vincent Jul 20 '15 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.