2

I'm trying to place an illustrator CC file with many artboards all into an Indesign CC file.

When I paste in the illustrations, the bounding boxes are giant.

When I place the file from file > Place, the quality of the illustrations is greatly diminished (looks very pixelated)

What is the proper way to move my file to indesign so I can place these illustrations in a book?

Thank you

  • 3
    What are your display settings? Fast, Typcial, High Quality? This will have a huge impact on the way ID displays graphics in-app. The final result is always better though, so I would export as a PDF to check it out, before you worry too much. Go to View > Display Performance – Manly Jun 22 '15 at 17:43
  • In addition to the answer(s) below: "placing" also allows you to toggle visibility of the file's layers/art boards from within inDesign, which is not available when pasting. Useful for e.g. logos/badges with alternate text – Yorik Jun 23 '15 at 19:03
  • Thank you all for the responses, Turns out the placed images weren't actually pixelated, but only appeared that way in InDesign. The quality was normal upon exporting. I won't paste anything in InDesign ever again! – Dboody Jun 26 '15 at 15:43
  • @Dboudro, a quick way to check (instead of exporting to a a PDF) is to just right click the image, then Display Performance > High Quality Display. – acook712 Jul 20 '15 at 14:20
4

Don’t paste content into InD!

Okay, that takes care of that nightmare. I’ll let others explain the limited exceptions to the rule.

Check your vector display settings

InDesign tries to spare your memory by displaying linked vector files in a pixelated preview mode. It assumes you know what it looks like. However, unless you’re working in a huge file on a sub-par workstation, it’s not necessary these days. Jump into your settings and drag that slider on up.

Depending on your version, the screen is pretty similar going a looong way back:

enter image description here

enter image description here

|improve this answer|||||
  • Nothing wrong with placing into InDesign. There's also a menu item where you can change the display settings to "high quality". It looks better, but can slow things down so you may not want to keep it on. The file will export and print fine no matter which setting you use. – Jeremy S. Jun 8 '17 at 11:46
  • @JeremyS. I didn't say there was anything wrong with "placing" Illustrator content. As I said, it's copying and pasting stuff between Illy and InD you want to avoid. – plainclothes Jun 8 '17 at 15:32
3

Using InDesign and linking to external files via File > Place is generally the best method.

While copy/pasting is certainly possible from Illustrator to InDesign, the paste can sometimes be problematic to edit later depending upon the actual artwork. Using the Place method allows you to edit the original, in Illustrator, then the link will update.

Placed vector images should look great if your display settings are set properly. Check View > Display Performance. I think by default it may be set to Typical. Try setting it to High Quality. You should see instant improvement in the display of your placed Illustrator files.

The display performance setting is there to allow you to view low resolution proofs while working in an effort to speed up screen redrawing. This was pretty critical many years ago when it was introduced. With the way technology moves, today's systems, and video cards, are capable of more faster so often you can simply leave it on 'High Quality` and forget about it.

To set the Display Performance setting default, with no document open in InDesign, choose the option you want from theView menu. Or, again with no document open set the Preferences > Display Performance to what you prefer.

|improve this answer|||||
  • "high quality" display settings will slow things down if you have complicated AI files placed even on a modern computer. I often toggle between different display settings depending on whether I want speed or good display quality. – Jeremy S. Jun 8 '17 at 11:48
0

Simple and fastest way. Save your illustrator vectors as an EPS or PDF (High Quality, or Press Quality). Then simply File > Place in InDesign.

|improve this answer|||||
0

I had the same problem and I created a new file in Illustrator with a much smaller art board. I moved the vector object (this is a logo) into the smaller file and sized it to fit the art board. I then moved it into InDesign and it was fine.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.