4

I'm working on a cloud image and have created triangles using a template. After the cut and coloring, there are gaps between the triangles. It' about 1 px thick, more prominent when exported to Photoshop:

There are gaps where the triangle edges touch/meet

Is there a quick fix for this?

Edit:

After adding a blue background and saving as a jpeg, the lines become even more visible. Note that I mean the tiny dark blue lines in the background, not the overlay/connection lines. Just curious as to whether there is a way to "expand" these paths.

enter image description here

7

There's a Path Offset feature in Illustrator that makes the path go out or in from the shape by an equal amount.

Traditionally this has been used to make fonts heavier or thinner. But will work perfectly for this, too.

Here's a video showing it being used for fonts, but I'm sure you'll immediately see how you can use this technique to solve your problem:

https://www.youtube.com/watch?v=A1-IFcvW1RI

It looks like you'll need a very small number, something like 0.5 might be enough.


Assuming your goal is to get the Polygons to all be joined perfectly, at their edges, like this:

enter image description here

In which case these 'triangles' are known as Polygons. Traditionally they're done in 3D programs. Which are now, apparently, beyond the scope of this forum. Which is interesting, because you've just highlighted the crossover between 2D and 3D, perfectly.

2

Complete Answer

Sometimes, the hairline gaps show not only on the software, but also when exporting (via File > Export).

To fix this, you have to select Art Optimized (Supersampling) from the Anti-aliasing option.


For PNG:

Adobe Illustrator export as PNG options


For JPG:

Adobe Illustrator export as JPG options


This is based from Jonathan Patterson's answer.

When you export (via File > Export, PNG) for example, under Anti-aliasing select Art Optimized.

0

This most likely not a real artifact, but just the program. Make sure pixel preview isn't on, also make sure that your shapes aren't aligned to pixel grid in the transform panel. Additionally, if you're using the new updated Illustrator, you can toggle back to CPU Preview, from the new GPU preview in the View menu. Again, these are just hairlines and won't show if printed. IF they really really bother you, just put a large rectangle of blue behind your whole design.

  • I'm used to the program doing this while not at optimal zoom levels, but usually my computer can handle this well. After exporting to Photoshop (or jpeg, png) the lines become visible. I will update the post with another image. – xsorifc28 Jun 30 '15 at 5:13
0

When you export (via File > Export, PNG) for example, under Anti-aliasing select Art Optimized.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 2
    Please complete your answer with better explanaition, for example by adding scrennshots showing what is to do ... Welcome to GD.SE! – Mensch Mar 30 '16 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.