4

In Indesign CC 2015, when I create a shape, by default it will add a black stroke to it. So if I need to create a 2 inches square for example, it will be 2 inches stroke included. But if I take off that stroke, but square will become 1,9861 inches. It does not do that in Illustrator. This is really annoying when trying to make some blocks for guiding me. I create my shape at the size I need, take off the stroke to see it better, and then I have to resize it to the size I want.

Is there a way to make it like Illustrator? Change it so adding or removing a stroke won't affect the size of the element?

5

This is common issue. In the Control panel menu located in the far upper-right corner of your screen, you’ll notice an option 'Dimensions Include Stroke Weight'. (via InDesignSecrets).

enter image description here

  • THIS. IS. BRILLIANT. – Lauren Ipsum Jul 1 '15 at 9:55
  • Awesome. Thanks a lot! I just tried it and it's working perfectly. Thanks again! – Danimp Jul 1 '15 at 12:08
0

A few useful tips you should be aware of (using CS6, but probably the same in CC):

  1. generally, the 'Stroke' panel in InDesign has a couple of useful settings called 'Align Stroke' with values for center, inside and outside. Experiment with these and see how they affect the size of your objects.
  2. for new documents: when in InDesign, close all documents then go to the swatches panel and set the stroke to 'None'. This will create any new objects in any new documents without a stroke.
  3. for existing documents: click anywhere outside any page and make sure no object is selected. Go to the swatches panel and set the stroke to 'None'. This will create any new objects in your current document without a stroke.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.