3

I made a blend of stars and chose the replace with spine command. The stars are not evenly spaced. I then decided to add anchor points and adjust them to try and space the stars evenly. Is there an easy way to distribute these stars evenly along an open path?

3

after replacing the spline, enter image description here

select the path and use Path->Simplify...and move Curve Precision to 100% enter image description here

1

It should work if you first make a blend between the two stars with specified steps (I chose 18) and then add anchor points to that path. See attached image

  • I made a curved open path with stars. The curve slopes down about 45 degrees and then slopes up about 45 degrees. The path does not have corner points just two bezier curves. The stars don't space evenly and I have to manually add anchor points and adjust their bezier handles to get them to space evenly. If you know of a simpler way, I'd love to hear it or see it. Thanks! – Mark Libetti Jun 30 '15 at 21:24
  • So it looks something like this? I think fiddling with the curve handles and trying to keep them parallel is your best bet. Or (getting into the weeds) expanding the shape and moving each star individually. ![attached][1] [1]: i.stack.imgur.com/zlSih.jpg – Jess J Jun 30 '15 at 21:36
  • Thanks for the link jess! Can you try adding space between your stars so I can see if it's my Illustrator settings? – Mark Libetti Jun 30 '15 at 21:45
  • Oh! I think I know the issue - trying converting the anchor points on both ends of the spine (shift+c) to have handles. Look what happens when those anchor points are just static points: ![attached][1] [1]: i.stack.imgur.com/9nqQb.jpg – Jess J Jun 30 '15 at 21:51
  • I'll try that! This is the url for what I have now. testdreamweaver.com/Test.html – Mark Libetti Jun 30 '15 at 21:55
0

While it seems like this should be easy.. it is not. The truth of the matter is, there's no way to control the spacing of objects in a blend accurately. Yes you can add anchors and push/pull handles to try and eyeball the spacing. However on a non-linear path, you'll almost always have uneven spacing in a live blend.

The only way around this is to expand the blend and manually align objects, or expand and use the distribute buttons on the Align Panel.

0

I see from your follow-up comments that this is a curved path. You said you added anchor points...were you doing that manually, with the Pen tool, eyeballing the intervals? Select the spine and then select Object > Path > Add Anchor Points...do that over and over again, and that should do the trick, though the objects still may not be perfectly spaced apart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.