0

My goal

I am saving CorelDraw files as AI files, and bringing them into Adobe Illustrator. I am then a text element.

My issue

When I'm creating a text element, spaces have no width, so "hello world" looks like "helloworld". There is a space, but it doesn't take up width. Even putting 10 spaces in a row cause no actual space to be taken up. This only happens with CorelDraw files that I saved as AI files and opening in Illustrator. Existing text from the old file does not have this issue, even when adding text to those elements. When I start a new project in illustrator, text on a path behaves as expected.

What I've tried

I've tried changing several settings both when saving the CorelDraw file as AI, and when bringing in the AI file. I've set the compatibility when saving the CorelDraw to both newer and older versions. I've tried with and without legacy artboard. I have tried different fonts. None of this has changed the behavior of spaces not taking up space.

I have searched google and the graphic design stack exchange, but have not found any relevant information.

UPDATE: Discovered this was not path specific, so removed references to doing this on a path. It applies to all new text elements.

  • When you open a CorelDraw in Illustrator if you draw a new path in Illustrator and then put your text on that path does it work correctly? – Ryan Jul 1 '15 at 17:40
  • Sounds like a bug in CorelDraw. – Scott Jul 1 '15 at 17:40
  • @Ryan no, spaces do not take up space when I try that. And to Scott,perhaps, but hopefully there is someway I can take these files, instead of recreating all of them, as there are thousands of them. – Goose Jul 1 '15 at 17:42
  • I don't know how anyone can fix a bug in Corel. The only option would appear to be paste text somewhere else that does honor the space character and then copy/paste the text into Illustrator. With a lot of files, I realize that's kind of a poor solution. Perhaps you should mention this to the folks at Corel. – Scott Jul 1 '15 at 20:35
0

I have had this problem when I save a Coreldraw document as an illustrator file, and then try and open it in Adobe Illustrator.

I have found that the solution is to save the Coreldraw document as a PDF, then open the PDF in illustrator.

  • 1
    Unfortunately I no longer have or work with CorelDraw, but thank you for the answer. – Goose Jul 18 '18 at 18:22
0

I am cheating answering this some years after the original post was made.

Use the latest versions you can afford.


Here is a screen capture of the Adobe Illustrator window of a file saved as AI from CorelDraw.

The first text is an "artistic text" and the second is "paragraph text" and both are working fine right out of the box.

enter image description here

  • Unfortunately I no longer have or work with CorelDraw, but thank you for the answer. – Goose Jul 18 '18 at 18:22
-1

Justification setting ... Minimum and Desired maybe is 80% ... change to 100%, then can see the spaces.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Please explain better what you mean. – Mensch Nov 27 '16 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.