Here i am getting extra line that i dont want.I tried scaling down the size of line but it did not help.So can you please guide me how to solve this type of errors.


2 Answers 2


You can change the stroke endpoint. If you do not have your stroke panel open you can go to Window - Stroke.

Select your path with the direct select tool. Go to the panel options and under Corner, select Round Join or Bevel Join

stroke options

If you are worried about lines protruding, you can also create an outside shape and use that as a clipping mask.



Well, take two lines that meet at a point.
When you make them bigger, you're basically drawing two parallel lines around the baseline and filling whatever is between those lines with your stroke fill color. So, the more acute the angle between your (base)lines, the farther the external parallels will meet, causing these spikes.


The Stroke panel has several corner options. Someone else already suggested that you go for a Round or Bevel join, but even if you select the regular join the Limit field will let you tell Illustrator how far this point can go before being automatically trimmed. Insert a value near to the line width and experiment a little.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.