After I have typed text onto an image using the text tool and then try to save it, the image turns into a kind of faintly transparent checker board.

Just to explain, above my text on an image layer in the layers box, there are two areas that add to my confusion. One is a grey rectangular box that has the word 'opacity' on the far left; then to the right are the numbers '100.0'. Below this is a whitish area that has on its left the word 'lock' and next to this word is an image of a paint brush and on the far right in this whitish area is a small square box showing a checker board.

Can anyone please help me? I've done something wrong but don't know what. I am new to GIMP.

1 Answer 1


In order to use transparencies with GIMP, you need to add an alpha layer. Check your Image Mode; if you are in Indexed or Grayscale mode, convert to RGB mode. The options for adding alpha layers (RGBA) will then be available.

The relevant parts of the documentation are:

4.7. Change the Mode

7.33. Add Alpha Channel

  • vallismortis your suggestions worked and I appreciate your help. Thanks. Regards janice4906
    – janice4906
    Jul 17, 2015 at 14:20
  • @janice4906 Great, I'm glad to hear it. Could you click the check mark next to my answer to mark this question as being answered?
    – Parker
    Jul 17, 2015 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.