New to Illustrator. When I open an ai CC file in CS6, all layers are compacted into one layer. How can I break it up into the original individual layers? How should I be saving my work to prevent this? Thanks

  • After rereading this... I'm not sure I understand your question. Layers should not magically be disappearing. Does this help? graphicdesign.stackexchange.com/questions/9001/… --
    – Scott
    Commented Aug 3, 2015 at 19:20
  • Thanks for your quick response Scott. So when I import a file, I can not edit individual shapes or vectors. The image is completely grouped and appearing as one solid layer composed of subgroups. The layers from the original file do not appear. Do I have to embed the file? Doesn't illustrator do that automatically for ai files?
    – NewB
    Commented Aug 3, 2015 at 19:34
  • Linked Illustrator files are not directly editable. They must be embedded or copy/pasted if you wish to edit them. Does that help?? I'm still kind of unclear on the issue.
    – Scott
    Commented Aug 3, 2015 at 19:58
  • How can I tell if they are linked? I didn't intentionally save them as linked. My main issue is that I can't freely edit files that I import, even though they're just regular ai files. I thought maybe it's due to them being from different versions (CC and CS6), could that be?
    – NewB
    Commented Aug 3, 2015 at 20:09
  • 1
    File > Open is opening the file not "importing" anything. But, Yes, the problem then is versioning. Illustrator CC files are not directly transferable to Illustrator CS6. You need to save to CS6 from CC if you intend to open the CC file in CS6. See here: graphicdesign.stackexchange.com/questions/38333/…
    – Scott
    Commented Aug 3, 2015 at 21:41

4 Answers 4


Files saved in Illustrator CC are not 100% compatible with earlier versions like CS6. Losing layers is the most common problem, so I'm pretty sure this is what caused yours.

If you want to back save an Illustrator CC file to CS6 without losing layers, you can follow these simple steps:

  1. Select 'Save As' (choose type Adobe Illustrator (*.AI)
  2. Open the second dialog box 'Illustrator Options'.
  3. The Illustrator Options dialog lets you choose the Illustrator Version in the dropdown box at the top.
  4. It is in this box where you want to choose Illustrator CS6 as the version to save.

I've run into this a lot, since I'm still using CS4. Just like Jascha said, each version of Illustrator will not be perfectly compatible with other versions, and if possible, just save the file again in the legacy format.

However, I have noticed when I open files from the newer versions, the elements are all grouped in weird ways, and sometimes it seems like the layers are all "compacted," but they're really just under a lot of clipping masks. You can go to the layers panel (Windows -> Layers) and open up each layer to see if this is the case. If you drill down into each layer and each group in the layer (by clicking on the dropdown arrows) and find a clipping mask as the last element in the group/layer, you can delete those clipping masks and start recovering your graphics.

This is very tedious, so only try it if you can't get the version re-saved, or if there aren't very many layers/groups. Definitely the last resort.


I have had this issue as well, when opening a CS6 file within CC. The way to 'ungroup' the layers is to click the physical layer in the layer panel, and click on the small horizontal bar button for the dropdown in the top right of the panel. From there you can select 'Release to layers' in either a build or sequence option which will expand the layer into its separate elements again. I'd search that separately if you want to know which to pick, I haven't quite figured out the difference yet... it seems one builds more into sublayers and one builds more from top down. Both unfortunately cause you to lose original layer names though.


"Show Layers Only" option in the "Layer Panel Options"

Click the hamburger lines in the top right of the Layers panel then go to "Layer Panel Options" at the bottom. Uncheck the "Show Layers Only" box

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.