4

I have a gif generated using Python. It looks like this:

To avoid the jump in resolution at the start, when is a good time in the animation to introduce the next layer?

EDIT:

Implementing fading in:

My Python code is here for whoever's interested

  • 2
    Maybe I'm too mesmerized to answer intelligently but I think this gif looks great as it is. For a gif it looks sharp, in my opinion. I'm not sure to see what you find is wrong with it I don't really see any "jump in resolution" but I might be wrong. – go-junta Aug 16 '15 at 3:46
3

One idea is to start fading the next layer in immediately, then it would not jerk. Im not sure this is better though. Or you can fade them in at any later point. Experiment.

Another idea, sprinkle the next layer, so the triangles keep popping up at random times. This saves you from the (possibly) extra shades that are needed. It may also look better. Offcourse you can still fade them in. They also dont have to begin poppring immediately on the beginning.

The triangles could also grow out by scaling from the triangle centers instead of popping into existence or shading.

Overall though im not so convinced you need any change, but test and see.

| improve this answer | |
  • It works ok: i.imgur.com/Nh6j31y.gif I'll try scaling next, but it will likely be much more difficult. For fading, I just had to generate each frame twice (one with the resolution higher than the other) and then blend the images together, but I will have to rework my code much more to generate scaling. – Luke Taylor Aug 16 '15 at 12:47
  • @LukeTaylor Check that you dont have the same frame 2 times in the start and end remember theres x-1 spaces between x posts. – joojaa Aug 16 '15 at 13:04
  • "X-1 spaces between x posts"? Not sure what you mean by that – Luke Taylor Aug 16 '15 at 13:05
  • @LukeTaylor It is a typical problem in animation, your interpolating between 0 and 1. then you make frames 0, 0.1, 0.2 ... 0.9 and 1. 0! Spiffy dory done right... But frame 0 and 1 is the same frame so you have the same frame 2 times you were supposed to stop at 0.9 not 1.0 – joojaa Aug 16 '15 at 13:11
  • The last and first frame are different. – Luke Taylor Aug 16 '15 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.