I have noticed that my exports are not as sharp as they look in the Artboard. To give an example am trying to export the Google Play Badge from this dribble file: https://dribbble.com/shots/1849549-Free-Vector-App-Store-Badges

But the text seems to be blurry.

The exported badge is blurry

  • Which text do you see as blurry? Any chance you're viewing this on a retina macbook? – DA01 Aug 18 '15 at 5:17
  • Hi if you see the export on the right "Get it on Google Play", its blurry. And yes am on retina mackbook ! – Shashank Aug 18 '15 at 16:18
  • It's not blurry to me...so my guess is that it's because you are on a retina macbook. Remember that some apps--like PhotoShop, are trying to show you 'actual sized' pixels but on a 2x screen. It's the macbook that's adding the blur--not the image itself. – DA01 Aug 18 '15 at 16:21
  • (Someone, please correct me if I am wrong)...I think if you want a true 1px in image = 1 real px on your retina screen, you need to view your images at 50% inside your editing software. Alas, I'm not that familiar with Sketch so not sure if that's the case in that particular program or not. – DA01 Aug 18 '15 at 16:23

This is a user interface problem.

If you examine actual pixel dimensions of the export preview item in your screen capture, the actual pixel dimensions of the preview are about 370 x 113 pixels.

If I am reading the screenshot properly, then your actual export settings appear to be 130 x 40 pixels.

The export preview is rendering an image as 130x40 and then stretching ("zooming" or "enlarging") that image by 3x when showing it to you.

This may be a byproduct/problem with the software UX running with high-density settings or MacOS "retina 2x" where the UX is being rendered at high pixel dimensions but simulating a 1920x1080 resolution (etc)

|improve this answer|||||
  • Thanks for the response. Its because of my display, I got confused. Any workaround so that its WYSIWYG. – Shashank Aug 28 '15 at 10:06
  • 2
    I don't use that software, nor OS, but the simplest workaround is to export it to an easy location and preview it 100% pixel size using a browser or image preview that won't "zoom in" on the pixels. You should be previewing on multiple devices as well. – Yorik Aug 28 '15 at 14:18

I was having this same issue. I have one of the new (retina?) Mac Pros. The default export setting is at 1x size. When I upped it to 2x and 3x, the resolution got better and better. 3x was optimal. Give that a shot!

Conclusion: Within Sketch 3, my art board looked sharp and was not pixelated. When I exported the board as a PNG or JPG, its default 1x export size yielded a result that seemed pixelated. When you up the export size to 3x, it should come out just as it looks within your Sketch app - sharp and beautiful! Note, you can see these changes in real time on the right hand side of your screen when you're playing with export settings. As soon as you click 2x and/or 3x, you'll notice the difference right in the export preview window.

Hope this helps! Cheers

|improve this answer|||||
  • 1
    This merely doubles or triples the pixel dimensions of the image. If the 1x pixel size is the specification, then 2x or 3x isn't an option. – Yorik Nov 19 '15 at 15:25

Don’t trust the preview

The export preview is just there for convenience*. You'll noticed that if you create additional exports for the same asset, there's still just one preview.

Pixel view is your friend

If you want to see the non-vector degradation, just switch on View > Canvas > Show pixels on Zoom (aka Ctrl + P). Now switch to 100% zoom and you'll see your work in all it's pixelated glory.

The exception

Sketch assumes you're building interface assets, not retouching your girlfriend's lazy eye. It's geared toward png. If you want to see how bad the jpg compression is, you'll need to export and check it in a browser or your favorite image viewer.

* You can actually drag the export from that thumbnail to a folder if you want.

|improve this answer|||||

I have downloaded your file from Dribble and export all 3 buttons in the file and the exported files are not blur at all at any size (1x, 2x, 3x). For the preview thumbnail image that you see at the right in the export section, I guess it is always blur like that :)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.