3

I'm creating a flyer in InDesign CS5.

I have an object at the top with a gradient fill and text over the object.

I tried to do a test print of the flyer, and the gradient isn't printing correctly. There is an area where it is missing color.

I've never seen InDesign do this before. I tried exporting it to PDF and printing from Acrobat but it still does the same thing.

Is there a way to fix this?

Here is a screenshot of my file.

This is how it is printing out.

  • 1
    It's your transparency effect of the shadow combined with that gradient. I have a solution for you but I generally get downvoted for these "other" options that offer bulletproof results and that always print as they should :) – go-junta Aug 26 '15 at 17:14
  • Well I am open to anything! – Sara Aug 26 '15 at 17:18
  • 1
    Put type and gradient on different layers in InDesign and check that you have layers in exported PDF also. Most cases it helps, because different transparency effects then are calculated separately and then combined. – mrserge Aug 26 '15 at 21:22
1

I'm not sure why your InDesign doesn't interpret well that transparency. Maybe you need to use PDFx or check your export settings. Personally I don't use much drop shadows and transparency in these software because of that kind of surprise or the white rectangles it often creates on the PDF. It's alright for printing but if you need that file for web too, it's very ugly.


If you want to try something else, here are some options.

1. Rasterize

This is not the ideal solution but you can rasterize that shadow title with the gradient background. Keep the rest of the layout not rasterized.

You'll still need to figure out why you had this issue from the start because rasterizing may be "ok" for a large title like this but you can't use this for small texts or small vectors.

2. The "before transparency" way

You can create that shadow under your text in Photoshop with the gradient under it already. Put that shadow on a "multiply" blend mode on its layer for nice results. Save this in your favorite file format (I still use .eps)

Then you can import that into the curved shape you created in InDesign and add the white text without any shadow on top of it.

The white text will be sharp and vector quality and gradient + shadow will be rasterized. That's personally how I do most of these things and that's how it was done before InDesign and Illustrator offered transparency.

It's quite easy to align perfectly if you create your Photoshop at the same file size at your InDesign and use the same values for your text formatting. Don't forget your bleed! If you put an equal bleed of 0.25" all around your Photoshop file and center that imported Photoshop file in your InDesign, it will align perfectly with the matching white title.

One trick to get the perfect alignment is also to export the white text only in a PDF (without any background) and with the crop marks on the PDF, and open that PDF in Photoshop; then change that text to black and add a gaussian blur on it. Your shadow will match perfectly with the white text you already had in InDesign this way and it's very quick too.


As to why exactly your PDF and InDesign removed entirely that portion of the layout, I have no answer on it besides trying other type of PDF settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.